Monday, December 5, 2011

Lab 167 - PIM BiDir

Prerequisites: CCNP level skills.


Topology

Pic. 1 - Topology Diagram.


Note!
Routers and switches are already configured as per the topology diagram. IP Multicast routing is enabled on all devices.

Task 1
Configure a solution for Video Conferencing software using 225.5.5.5 group address. R1 should be the distribution point of this single shared tree.

Solution


Task 1
Configure a solution for Video Conferencing software using 225.5.5.5 group address. R1 should be the distribution point of this single shared tree.

R1 Configuration:
!
ip pim bidir-enable
!
ip access-list standard MULTICAST_225.5.5.5
 permit 225.5.5.5
!
ip pim rp-candidate Loopback101 group-list MULTICAST_225.5.5.5 bidir
!
ip pim bsr-candidate Loopback101 0
!



All Other Devices Configuration:
!
ip pim bidir-enable
!

Verification:

IGMP join-group on S1, S2, R6. Ping from R1 to 225.5.5.5 is getting response. Example of mroute table on R5 for the group:

Pic. 2 - Mroute Table on R5.

Note!

DF Election
On every network segment and point-to-point link, all PIM routers participate in a procedure called DF election. The procedure selects one router as the DF for every RP of bidirectional groups. This router is responsible for forwarding multicast packets received on that network upstream to the RP.

The DF election is based on unicast routing metrics and uses the same tie-break rules employed by PIM assert processes. The router with the most preferred unicast routing metric to the RP becomes the DF. Use of this method ensures that only one copy of every packet will be sent to the RP, even if there are parallel equal cost paths to the RP.

A DF is selected for every RP of bidirectional groups. As a result, multiple routers may be elected as DF on any network segment, one for each RP. In addition, any particular router may be elected as DF on more than one interface.



source:
http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfbipim.html

Lab 166 - Multicast Helper Map

Prerequisites: CCNP level skills.

Personal Note!
OMG, it is already December! What happened to all previous months?! Did I doze off or something? Nah! It was the work.

All the work and no play (or study) make J a dull boy.
All the work and no play (or study) make J a dull boy.
All the work and no play (or study) make J a dull boy.
All the work and ...

Topology

Pic. 1 - Topology Diagram.


Note!
Routers and switches are already configured as per the topology diagram. IP Multicast routing is enabled on all devices.

Task 1
Configure multicast sparse mode between R1 and R2 on WAN link. R1 should be configured as RP.

Task 2
An application on VLAN 26 will broadcast UDP traffic to port 30000. Configure routers in such a way as to allow this broadcast to be converted into multicast 239.1.1.1 address on the WAN link between R1 and R2. This traffic should be converted back into broadcast on VLAN 14.


Solution


Task 1
Configure multicast sparse mode between R1 and R2 on WAN link. R1 should be configured as RP.


R1 Configuration:

!
ip pim rp-address 172.16.101.1
!
interface Loopback101
 ip address 172.16.101.1 255.255.255.255
 ip pim sparse-mode
!
interface Serial0/0.125 multipoint
 ip address 10.1.125.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-multipoint
 snmp trap link-status
 frame-relay map ip 10.1.125.1 102
 frame-relay map ip 10.1.125.5 105 broadcast
 frame-relay map ip 10.1.125.2 102 broadcast
!


R2 Configuration:

!
ip pim rp-address 172.16.101.1
!
interface Serial0/0
 ip address 10.1.125.2 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 clock rate 2000000
 frame-relay map ip 10.1.125.5 201
 frame-relay map ip 10.1.125.1 201 broadcast
 frame-relay map ip 10.1.125.2 201
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 ip address 10.1.26.2 255.255.255.0
 ip pim sparse-mode
 speed 100
 full-duplex

!



Note!

For the Task 2 configuration to work (broadcast on Fa0/1 of R2), the multicast has to be enabled on Fa0/1 interface of R2.



Task 2
An application on VLAN 26 will broadcast UDP traffic to port 30000. Configure routers in such a way as to allow this broadcast to be converted into multicast 239.1.1.1 address on the WAN link between R1 and R2. This traffic should be converted back into broadcast on VLAN 14.

R1 Configuration:
!
ip access-list extended UDP30000
 permit udp any any eq 30000
 permit udp any any eq domain
!
ip forward-protocol udp 30000
!
interface FastEthernet0/0
 ip address 10.1.14.1 255.255.255.0
 ip broadcast-address 10.1.14.255
 ip directed-broadcast
 speed 100
 full-duplex
!
interface Serial0/0.125 multipoint
 ip address 10.1.125.1 255.255.255.0
 ip pim sparse-mode
 ip multicast helper-map 239.1.1.1 10.1.14.255 UDP30000
!
 
NOTE!
ACL entry with UDP 53 port (domain) was added only for testing purposes here.

R2 Configuration:
!
ip forward-protocol udp 30000
!
ip access-list extended UDP30000
 permit udp any any eq 30000
 permit udp any any eq domain
!
interface FastEthernet0/1
 ip address 10.1.26.2 255.255.255.0
 ip multicast helper-map broadcast 239.1.1.1 UDP30000
 speed 100
 full-duplex
!

NOTE!

ACL entry with UDP 53 port (domain) was added only for testing purposes here.
Verification:

On R6 I have enabled ip domain-lookup and mistyped the command in the privilege mode to create UDP broadcast port 53. On R4 I have created an access-list enabled debug ip packet using it to see if R1 is sending broadcast. The results are below.


R4 Configuration:
!
access-list 100 permit udp any 10.1.14.255 0.0.0.0
!
R4#debug ip packet detail 100

Pic. 2 - R2 Forwards Broadcast as Multicast.


 Pic. 3 - Debug IP Packet on R4.