Thursday, June 16, 2011

Lab 156 - PIM NBMA

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse Mode!

Topology
Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
R5 has been configured to be the RP/MA for all multicast groups in this topology (auto-rp is used). R2's Et0/0 must emulate the client of multicast group 224.24.24.24. R4 must stream packets to this group. Make sure the client receives this traffic.

Solution

Task 1
R5 has been configured to be RP/MA for all multicast groups in this topology (auto-rp is used). R2's Et0/0 must emulate the client of multicast group 224.24.24.24. R4 must stream packets to this group. Make sure the client receives this traffic.

R2 Configuration
!
interface Ethernet0/0
 ip address 10.1.2.2 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 224.24.24.24
!

Verification:
Pic. 2 - (*, G) for 224.24.24.24 Registered.

Ping from R4 to 224.24.24.24 does not work now.

Pic. 3 - Ping from R6.

However, the (S, G) entry shows in RP (multicast sender). The problem is that multicast reaching R1's S1/0 cannot be sent back out S1/0. 
Pic. 4 - Mroute Table in R1.

Note!
R1 cannot send multicast back out the interface it received this feed. However, using PIM Sparse Mode we can accomplish this using PIM NBMA. This mode can reflect the traffic back out the same interface it received the traffic. In addition to this it will send the multicast only out the circuits which have the clients registered for the group. For example, if R6 sends the traffic towards R2 (group registered there), and R3 did not register the group, R1 sends the multicast packets out of all its circuits in hub-and-spoke FR topology (towards R2 and R3). With PIM NBMA turned on, only circuits that registered the clients, will receive the feed.

R1 Configuration:
!
interface Serial1/0
 ip address 10.1.123.1 255.255.255.0
 ip pim nbma-mode
 ip pim sparse-mode
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 serial restart-delay 0
 frame-relay map ip 10.1.123.3 103 broadcast
 frame-relay map ip 10.1.123.2 102 broadcast
 no frame-relay inverse-arp
!

Ping from R4 to 224.24.24 succeeds now.

Verification:
Pic. 5 - Ping from R4.

Pic. 6 - Mroute Table in R1.

Monday, June 13, 2011

Lab 155 - Multicast Traffic Boundary

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse Mode!

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Configure R5 so that it does not send the administratively scoped multicast address space towards R6.

Solution

Task 1
Configure R5 so that it does not send the administratively scoped multicast address space towards R6.

R5 Configuration:
!
access-list 1 deny   239.0.0.0 0.255.255.255
access-list 1 permit any
!
interface Ethernet0/0
 ip address 10.1.56.5 255.255.255.0
 ip pim sparse-mode
 ip multicast boundary 1
!

Note!
Administratively scoped multicast range is: 239.0.0.0/8.

Note!
Read the whole description of the command usage:
http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_03.html#wp1071517

Lab 154 - Auto-RP Scope Limiting

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse Mode!

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
R1 is the RP and MA in the multicast domain. Ensure that R1 does not become RP and MA beyond the domain pictured in the topology diagram (pic. 1).

Solution

Task 1
R1 is the RP and MA in the multicast domain. Ensure that R1 does not become RP and MA beyond the domain pictured in the topology diagram (pic. 1).

R1 Configuration:
!
ip pim send-rp-announce Loopback0 scope 2
ip pim send-rp-discovery Loopback0 scope 2
!

Note!
By limiting the TTL of the RP/MA announcements to two hops, routers beyond R6 and R4 will not receive the these messages.

Sunday, June 12, 2011

Lab 153 - PIM Accept Register

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse Mode.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
R1 is the RP and MA in the multicast domain. Configure R1 so it allows all multicast group registration only if it sourced by 10.1.234.4. All other sources should be denied.

Solution

Task 1
R1 is the RP and MA in the multicast domain. Configure R1 so it allows all multicast group registration (multicast stream) only if it sourced by 10.1.234.4 (server). All other sources should be denied.

R1 Configuration:
!
ip access-list extended ALLOWED_SOURCES
 permit ip host 10.1.234.4 224.0.0.0 15.255.255.255
!
ip pim accept-register list ALLOWED_SOURCES
!

Verification:
Pic. 2 - R3's Group Registration Attempt
(Server Address 10.1.123.3.).

R1 (RP) refuses to register the multicast source 10.1.234.3

Lab 152 - PIM Accept RP

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse Mode.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Based on the previous lab (Lab 151), R1 is the RP and MA (Mapping Agent) for all groups. As per your boss request, you must configure R2 and R3 so that routers should register (*, G) entries only for the group 224.40.40.40 and can be destined for 172.16.101.1 (RP).This group cannot be registered with any other RP.

Solution

Task 1
Based on the previous lab (Lab 151), R1 is the RP and MA (Mapping Agent) for all groups. As per your boss request, you must configure R2 and R3 so that routers should register (*, G) entries only for the group 224.40.40.40 and can be destined for 172.16.101.1 (RP). This group cannot be registered with any other RP.

R2 Configuration:
!
access-list 10 permit 224.40.40.40
!
ip pim accept-rp 172.16.101.1 10
!

R3 Configuration:
!
access-list 10 permit 224.40.40.40
!
ip pim accept-rp 172.16.101.1 10
!

Verification:
Pic. 2 - Another Group Registration.

After R4 have joined the 224.64.64.64, R1 (RP) does not have the group registered. It has been pruned on R2 (PIM DR).

Pic. 3 - R2 (PIM DR) Prunes the Join Message.


R2 does not build the 'register message' and the group has not been registered with RP.

Lab 151 - PIM DR Election

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse Mode.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
All routers in the topology run PIM Sparse Mode. Configure R1 as both the RP and the Mapping Agent for all multicast groups. Use Auto-RP to disseminate this information. Do not change the PIM Mode (Sparse Mode). RP should advertise itself as RP every 10 seconds.

Task 2
Configure R4's Et0/0 interface to join the group 224.40.40.40. Ensure that R2 registers the group with the RP.

Solution

Task 1
All routers in the topology run PIM Sparse Mode. Configure R1 as both the RP and the Mapping Agent for all multicast groups. Use Auto-RP to disseminate this information. Do not change the PIM Mode (Sparse Mode). RP should advertise itself as RP every 10 seconds.

All Routers Configuration:
!
ip pim autorp listener
!

R1 Configuration:
!
interface Loopback0
 ip address 172.16.101.1 255.255.255.0
 ip pim sparse-mode
!
ip pim send-rp-announce Loopback0 scope 16 interval 10
ip pim send-rp-discovery Loopback0 scope 16 interval 10
!

Task 2
Configure R4's Et0/0 interface to join the group 224.40.40.40. Ensure that R2 registers the group with RP. 

Before configuring the 'igmp join-group' let's see which router is the DR on the subnet.

Pic. 1 - DR on 10.1.234.0/24

Note!
Since all routers have the same priority (p=1), the highest IP address (here: R4) has been elected to be PIM DR on this segment. DR is responsible for registering multicast clients/multicast feed with RP (group/multicast traffic registration). Unlike OSPF's DR, the PIM DR role is preemptive.

R2 Configuration:
!
interface Ethernet0/0
 ip address 10.1.234.2 255.255.255.0
 ip pim dr-priority 50
 ip pim sparse-mode
!

Pic. 3 - R2 Becomes PIM DR.

R2 is the PIM DR now. It registers the group 224.40.40.40 with RP (look below).

Pic 4 - R2's Group Registration.

Friday, June 10, 2011

Lab 150 - Auto-RP Listener

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse-Dense!

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
All routers in the topology run PIM Sparse Mode. Configure R1 as RP for all multicast group and R2 as the Mapping Agent. Do not change the PIM mode to accomplish this.

Solution

Task 1
All routers in the topology run PIM Sparse Mode. Configure R1 as RP for all multicast group and R2 as the Mapping Agent. Do not change the PIM mode to accomplish this.

Note!
The problem I'm going to run into is that in order for a router to advertise itself as the RP candidate, it needs to know which router is RP (none available at the moment) since Auto-RP uses multicast address 224.0.1.39 to announce it. Also, the Mapping Agent must register the group 224.0.0.40 with RP in order to announce which device is RP. One solution to this problem is to use PIM Sparse-Dense Mode. But the lab stipulates, that PIM Sparse Mode currently configured cannot be changed.

Another solution is to use Auto-RP Listener option on all routers in the multicast domain. This feature, allows the RP candidate and the Mapping Agent advertise these two groups out the PIM Sparse Mode interfaces as Dense Mode.

R1 Configuration:
!
interface Loopback0
 ip address 172.16.101.1 255.255.255.0
 ip pim sparse-mode
!
ip pim autorp listener
!
ip pim send-rp-announce loopback0 scope 16
!

R2 Configuration:
!
interface Loopback0
 ip address 172.16.102.2 255.255.255.0
 ip pim sparse-mode
!
ip pim autorp listener
!
ip pim send-rp-discovery loopback0 scope 16
!

All Other Routers:
!
ip pim autorp listener
!

Verification:
Pic. 2 - RP Information on R6.


All routers learn which device is RP.


Lab 149 - Auto-RP Filtering

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All transit interfaces have been configured as Sparse-Dense-Mode.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Using Auto-RP, configure R1 to be RP candidate for the multicast group 224.10.10.10. R5 must be elected as the Mapping Agent. Ensure that no other router can become RP candidate for any other multicast group in the network.

Solution

Task 1
Using Auto-RP, configure R1 to be RP candidate for the multicast group 224.10.10.10. R5 must be elected as the Mapping Agent. Ensure that no other router can become RP candidate for any other multicast group in the network.

R1 Configuration:
!
interface Loopback0
 ip address 172.16.101.1 255.255.255.0
 ip pim sparse-dense-mode
!
access-list 1 permit 224.10.10.10
!
ip pim send-rp-announce loopback0 scope 16 group-list 1
!

R5 Configuration:
!
interface Loopback0
 ip address 172.16.105.5 255.255.255.0
 ip pim sparse-dense-mode
!
ip pim send-rp-discovery loopback0 scope 16
!
ip pim rp-announce-filter rp-list R1_RP group-list MULTICAST_GROUPS
!
ip pim rp-announce-filter rp-list ROUGE_RPS group-list ALL_MULTICAST_GROUPS 
!
ip access-list standard R1_RP
 permit 172.16.101.1
!
ip access-list standard MULTICAST_GROUPS
 permit 224.10.10.10
!
ip access-list standard ROUGE_RPS
 deny   172.16.101.1
 permit any
!
ip access-list standard ALL_MULTICAST_GROUPS
 deny   224.0.0.0 15.255.255.255
!

Verification:

Configuring R2 as a 'rouge' RP for a group 224.2.2.2, which should not be advertised by R5 (Mapping Agent).

R2 Configuration:
!
interface Loopback0
 ip address 172.16.102.2 255.255.255.0
 ip pim sparse-dense-mode
!
access-list 1 permit 224.2.2.2
!
ip pim send-rp-announce Loopback0 scope 16 group-list 1
!

Pic. 2 -Debug PIM Auto-RP on R5 (Mapping Agent).

Rouge RP has been filtered out.


Note!
"Use this command with caution (ip pim rp-announce-filter rp-list - JR). RPs that are matched by rp-list (allowed by a permit statement) have their multicast groups filtered by group-list. RPs that are denied (either by an explicit or implicit deny) are not subject to the filtering of their multicast groups and are "blindly" accepted as candidate RPs for all of their groups. In other words, only RPs that are permitted by rp-list have their multicast-groups filtered by group-list. All other RPs are accepted without examination".
source: http://www.cisco.com/en/US/tech/tk828/technologies_configuration_example09186a00801cb923.shtml#filter

Monday, June 6, 2011

Lab 148 - Cisco Auto-RP Multple RPs

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing. All interfaces have been configured as Sparse-Dense-Mode.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
The routers in the topology run multicast routing. The transit interfaces use sparse-dense-mode. In order to split the RP's load in half, configure R2 to advertise its loopback as the candidate RP for groups for groups 224.0.0.0 - 231.255.255.255. Configure R3 to advertise its loopback as the candidate RP for groups 232.0.0.0.0 - 239.255.255.255. R4 should be their Mapping Agent.

Solution

Task 1
The routers in the topology run multicast routing. The transit interfaces use sparse-dense-mode. In order to split the RP's load in half, configure R2 to advertise its loopback as the candidate RP for groups for groups 224.0.0.0 - 231.255.255.255. Configure R3 to advertise its loopback as the candidate RP for groups 232.0.0.0.0 - 239.255.255.255. R4 should be their Mapping Agent.

R2 Configuration:
!
interface Loopback0
 ip address 172.16.102.2 255.255.255.0
 ip pim sparse-dense-mode
!
access-list 1 permit 224.0.0.0 7.255.255.255
!
ip pim send-rp-announce loopback0 scope 16 group-list 1
!

R3 Configuration:
!
interface Loopback0
 ip address 172.16.103.3 255.255.255.0
 ip pim sparse-dense-mode
!
access-list 1 permit 232.0.0.0 7.255.255.255
!
ip pim send-rp-announce loopback0 scope 16 group-list 1
!

R4 Configuration:
!
interface Loopback0
 ip address 172.16.104.4 255.255.255.0
 ip pim sparse-dense-mode
!
ip pim send-rp-discovery loopback0 scope 16
!


Verification:
Pic. 2 - RP Mapping.

Pic. 3 - R2's RP Announcement.

Pic. 4 - R3's RP Announcement.

Lab 147 - Cisco Auto-RP

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Configure PIM on all router's transit interfaces in the topology diagram (pic.1) allowing Cisco Auto-RP. R1's Loopback should be advertised  as RP candidate for the groups 224.6.6.0 - 224.6.6.255. R5's Loopback should be advertised as the Mapping Agent. Auto-RP advertisements should be sent every 10 seconds. Ensure, that routers do not use PIM Dense-Mode for the unknown groups.

Solution

Task 1
Configure PIM on all router's transit interfaces in the topology diagram (pic.1) allowing Cisco Auto-RP. R1's Loopback should be advertised as RP candidate for the groups 224.6.6.0 - 224.6.6.255. R5's Loopback should be advertised as the Mapping Agent. Auto-RP advertisements should be sent every 10 seconds. Ensure, that the routers do not use PIM Dense-Mode for the unknown groups.

All Transit Interfaces:
!
ip pim sparse-dense-mode
!

All PIM-Sparse-Dense-Mode Routers
!
no ip pim dm-fallback
!

Note!
PIM Sparse-Dense-Mode is used to resolve the problem of advertising a router as the RP candidate. Auto-RP uses two multicast addresses:
  • 224.0.1.39 - Cisco-RP-Announce
  • 224.0.1.40 - Cisco-RP-Discover
In order to advertise itself as a RP, the router must know which router is RP first to register 224.0.1.39 group (its multicast announcement). Since, there is no RP elected yet, the candidate RP cannot register itself and announce itself as RP. Sparse-Dense-Mode solves this vicious circle. The groups 224.0.1.39 and 224.0.1.40 are flooded as the Dense-Mode since the RP is not know for these groups. The caveat with the Sparse-Dense-Mode is that the groups not registered will also be treated as Dense-Mode flooding all subnets. To prevent this from happening the 'no ip pim dm-fallback' command is used.

R1 Configuration:
!
interface Loopback0
 ip address 172.16.101.1 255.255.255.0
 ip pim sparse-dense-mode
!
access-list 1 permit 224.6.6.0 0.0.0.255
!
ip pim send-rp-announce Loopback0 scope 16 group-list 1 interval 10
!

R5 Configuration:
!
interface Loopback0
 ip address 172.16.105.5 255.255.255.0
 ip pim sparse-dense-mode
!
!
ip pim send-rp-discovery loopback0 scope 16 interval 10
!

Note!
Both the candidate RP and Mapping Agent, must have their loopback enabled for any PIM mode.

Verification (on all routers: here R6 only):
Pic. 2 - R6's Auto-RP Info.

R6 Configuration:
!
interface Ethernet0/0
 ip address 10.1.56.6 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 224.6.6.6
!

Pic. 3 - Ping Test.

Pic. 4 - RP Announcements.

Sunday, June 5, 2011

Lab 146 - PIM RPF Failure 2

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
All routers have PIM Dense enabled on all their interfaces except for subnet (use R6's Et0/0). 10.1.51.0/24. The multicast clients on subnet 10.1.56.0/24 join 224.6.6.6 group.  Ensure that multicast clients can receive feed from 10.1.234.0/24 (R4).

Solution

Task 1
All routers have PIM Dense enabled on all their interfaces except for subnet 10.1.51.0/24. The multicast clients on subnet 10.1.56.0/24 will join 224.6.6.6 group (use R6's Et0/0). Ensure that multicast clients can receive feed from 10.1.234.0/24 (R4).

R6 Configuration:
!
interface Ethernet0/0
 ip address 10.1.56.6 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 224.6.6.6
!


Verification:
Pic. 2 - Feed from R4 towards 224.6.6.6.

The feed does not reach the subnet 10.1.56.0/24. The reason is the Reverse Path Forwarding check failure according to IGP routing between R1 and R5. Like in the previous lab, where reaching RP is a subject to RPF check, here R1 picks the path through 10.1.51.0/24 to reach 10.1.56.0/24. These interfaces are not PIM enabled. 

Pic. 3 - R1's Routing Table.

The RPF check fails since the multicast traffic arrives on R5's Et0/1 interface instead of Se1/0.

Pic. 4 - R5's RPF Check Failure.

Pic. 5 - R5's IOL List.

In order to correct the problem, static mroute must be configured on R5.

R5 Configuration:
!
ip mroute 10.1.234.0 255.255.255.0 10.1.15.1
!

Pic. 6 - Multicast Feed Works.

Note!
Cisco's PIM based multicast traffic as well as the reachability towards RP (Sparse-Mode), are the subject to RPF check.

Lab 145 - PIM RPF Failure

Prerequisites: CCNP level skills.

Note!
All routers are running EIGRP protocol as well as multicast routing.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Configure multicast domain using the topology diagram. The multicast clients on subnet 10.1.234.0/24 will join 224.4.4.4 group. Ensure that multicast traffic is distributed to the clients which join the group explicitly. Do not enable multicast on 10.1.51.0/24 subnet. R5 should become RP in the multicast domain.

Task 2
Configure R4's Et0/0 to join the group 224.4.4.4. On R6 use ping to verify if R4 receives the multicast traffic.

Solution

Task 1
Configure multicast domain using the topology diagram. The multicast clients on subnet 10.1.234.0/24 will join 224.4.4.4 group. Ensure that multicast traffic is distributed to the clients which join the group explicitly. Do not enable multicast on 10.1.51.0/24 subnet. R5 should become the RP in the multicast domain.

R1 Configuration:
!
ip multicast-routing 
!
ip pim rp-address 172.16.105.5
!
interface Serial1/0
 ip address 10.1.123.1 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 serial restart-delay 0
 frame-relay map ip 10.1.123.2 102 broadcast
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 10.1.15.1 255.255.255.0
 ip pim sparse-mode
 serial restart-delay 0
!

R2 Configuration:
!
ip multicast-routing
!
ip pim rp-address 172.16.105.5
!
interface Ethernet0/0
 ip address 10.1.234.2 255.255.255.0
 ip pim dr-priority 20
 ip pim sparse-mode
!
interface Serial1/0
 ip address 10.1.123.2 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.1.123.1 201 broadcast
 frame-relay map ip 10.1.123.3 201
 no frame-relay inverse-arp
!

Note!
The 'ip pim dr-priority 20' is configured so R2 sends the pim join message on behalf of 10.1.234.0/24 subnet. R4 becomes multicast DR by default. I have found that if R4 joins the group, it does not want to send the register message at the same time. That's why I make R2 the DR for this subnet.

R3 Configuration:
!
ip multicast-routing
!
ip pim rp-address 172.16.105.5
!
interface Ethernet0/0
 ip address 10.1.234.3 255.255.255.0
 ip pim sparse-mode
!
interface Serial1/0
 ip address 10.1.123.3 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.1.123.1 301 broadcast
 frame-relay map ip 10.1.123.2 301
 no frame-relay inverse-arp
!

R4 Configuration:
!
ip multicast-routing
!
ip pim rp-address 172.16.105.5
!
interface Ethernet0/0
 ip address 10.1.234.4 255.255.255.0
 ip pim sparse-mode
!

R5 Configuration:
!
ip multicast-routing
!
ip pim rp-address 172.16.105.5
!
interface Ethernet0/0
 ip address 10.1.56.5 255.255.255.0
 ip pim sparse-mode
!
interface Serial1/0
 ip address 10.1.15.5 255.255.255.0
 ip pim sparse-mode
 serial restart-delay 0
!

R6 Configuration:
!
ip multicast-routing
!
ip pim rp-address 172.16.105.5
!
interface Ethernet0/0
 ip address 10.1.56.6 255.255.255.0
 ip pim sparse-mode
!

Verification:
The 'show ip pim interface' and 'show ip pim neighbor' commands show proper output.

Task 2
Configure R4's Et0/0 to join the group 224.4.4.4. On R6 use ping to verify if R4 receives the multicast traffic.

R4 Configuration:
!
interface Ethernet0/0
 ip address 10.1.234.4 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 224.4.4.4
!

Note!
The problem here, is that for R1 to reach the RP (172.16.105.5) the best path is through Ethernet (10.1.51.0/24). These interfaces are not enabled for PIM. As a result of this, the PIM join message will not reach the RP and the group is not going to be registered.

Verification:
Pic. 2 - R2 (DR) Multicast Routing Table.

Pic. 3 - R5 (RP) Does Not Register 224.4.4.4


The reason for not sending the group register message is that R1's routing table points towards RP out its Et0/0 rather than Se1/1. But Eth0/0 is not enabled for multicast.

In order to solve the problem, I must force R1's multicast protocol into believing that connection towards 172.16.105.5 out its s1/1 interface is better than given by the EIGRP protocol.

R1 Configuration:
!
ip mroute 172.16.105.5 255.255.255.255 10.1.15.5
!

Pic. 4 - R5 (RP) Registers 224.4.4.4 Group.

Pic. 5 - Ping Test.