Showing posts with label IPv6. Show all posts
Showing posts with label IPv6. Show all posts

Sunday, February 10, 2013

Lab 212 - IPv6 MP-BGP


Prerequisites: CCNP level skills.

Topology

Pic 1. Topology Diagram.

Task 1
Using previous lab's IPv6 configuration, create new loopback interface on R1 and SW2. Use the following IPv6 addresses:
  • R1 - Loopback1 = 2002:a00:101:1111::1/128
  • SW2 - Loopback1 = 2002:a00:101:8888::8/128
Task 2
Enable IPv6 MP-BGP peering between R1 (AS100) and SW2 (AS800). Advertise IPv6 addresses configured on Loopback1 interface of both devices into IPv6 MP-BGP. Check the connectivity.

Solution

Task 1
Using previous lab's IPv6 configuration, create new loopback interface on R1 and SW2. Use the following IPv6 addresses:
  • R1 - Loopback1 = 2002:a00:101:1111::1/128
  • SW2 - Loopback1 = 2002:a00:101:8888::8/128
R1 Config:
!
interface Loopback1
 no ip address
 ipv6 address 2002:A00:101:1111::1/128
!


SW2 Config:
!
interface Loopback1
 no ip address
 ipv6 address 2002:A00:101:8888::8/128
!

  
Task 2
Enable IPv6 BGP peering between R1 (AS100) and SW2 (AS800). Advertise IPv6 addresses configured on Loopback1 interface of both devices into IPv6 MP-BGP. Check the connectivity.

R1 Config:
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 2002:A00:101:D7::8 remote-as 800
 no neighbor 2002:A00:101:D7::8 activate
 no auto-summary
 !
 address-family ipv6
  neighbor 2002:A00:101:D7::8 activate
  network 2002:A00:101:1111::1/128
 exit-address-family
!


NOTICE!
The configuration of IPv6 address family may be different on your router. It depends on the IOS version you use (neighbor and network statements should be configured in ipv6 address-family but may show like in my example).

SW2 Config:
!
router bgp 800
 no synchronization
 bgp log-neighbor-changes
 neighbor 2002:A00:101:D7::1 remote-as 100
 no neighbor 2002:A00:101:D7::1 activate
 no auto-summary
 !
 address-family ipv6
  neighbor 2002:A00:101:D7::1 activate
  network 2002:A00:101:8888::8/128
 exit-address-family

!


Verification:
Pic. 2 - IPv6 MP-BGP Neighbor.

Pic. 3 - IPv6 MP-BGP Table.

Pic. 4 - Connectivity Test.

Sunday, February 3, 2013

Lab 211 - Automatic 6to4 Tunnel


Prerequisites: CCNP level skills.

Topology

Pic 1. Topology Diagram.

Task 1
Enable connectivity between two IPv6 sites (presented in the topology diagram in green). Vlans 7, 9, 27, 79, 99, 107 should have connectivity to Vlan 215. The following stipulations should be considered while creating the solution to the problem:
  • The tunnel IPv6 address should use 2002:: prefix reserved for this method.
  • You are allowed to use one static route on R1 and SW4 to solve the problem.
  • Use RIPng on both sites, but there is not supposed to be RIPng prefix exchange between Vlan 215 and other Vlans on the remote site.

Solution

Task 1
Enable connectivity between two IPv6 sites (presented in the topology diagram in green). Vlans 7, 9, 27, 79, 99, 107 should have connectivity to Vlan 215. The following stipulations should be considered while creating the solution to the problem:
  • The tunnel IPv6 address should use 2002:: prefix reserved for this method.
  • You are allowed to use one static route on R1 and SW4 to solve the problem.
  • Use RIPng on both sites, but there is not supposed to be RIPng prefix exchange between Vlan 215 and other Vlans on the remote site.

The method implies Automatic 6to4 tunnelling. Configure appropriate addressing scheme for all the Vlans in question. The method assumes the following prefix to be used:
2002:border-router-ipv4-address-in-hex::/48

Step 1
Create addressing scheme for all Vlans in question and the tunnel interface.

Border-Router-Prefix (based on the loopbacks) of R1 and SW4 (leading 0s in IPv6 address groups can be omitted).

Step 2
Configure the addresses on all interfaces in question and enable RIPng on those.

Vlans:
Dec: 7     ==> Hex: 7
Dec: 9     ==> Hex: 9
Dec: 27   ==> Hex: 1B
Dec: 79   ==> Hex: 4F
Dec: 99   ==> Hex: 63
Dec: 107 ==> Hex: 6B
Dec: 215 ==> Hex: D7


Site 1 (behind R1) Addressing Scheme (based off of R1's Loopback0):
2002:A00:101::/48

Site 2 (behind SW4) Addressing Scheme (based off of SW4's Loobpack0):
2002:A00:A0A::/48

Pic. 2 - IPv6 addresses.

SITE 1 ADDRESSES

R1 IPv6 Address and RIPng Config:
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 ipv6 address 2002:A00:101:D7::1/64
 ipv6 rip CCIE enable
!


R5 IPv6 Address and RIPng Config:
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 ipv6 address 2002:A00:101:D7::5/64
 ipv6 rip CCIE enable
!


SW2 IPv6 Address and RIPng Config:
!
interface Vlan215
 no ip address
 ipv6 address 2002:A00:101:D7::8/64
 ipv6 rip CCIE enable
!


SITE 2 ADDRESSES

SW1 IPv6 Address and RIPng Config:
!
interface Vlan7
 no ip address
 ipv6 address 2002:A00:A0A:7::7/64
 ipv6 rip CCIE enable
!

interface Vlan79
 no ip address
 ipv6 address 2002:A00:A0A:4F::7/64
 ipv6 rip CCIE enable
!

interface Vlan107
 no ip address
 ipv6 address 2002:A00:A0A:6B::7/64
 ipv6 rip CCIE enable
!

interface FastEthernet1/2
 no switchport
 no ip address
 duplex full
 speed 100
 ipv6 address 2002:A00:A0A:1B::7/64
 ipv6 rip CCIE enable
!


SW3 IPv6 Address and RIPng Config:
!
interface Vlan9
 no ip address
 ipv6 address 2002:A00:A0A:9::9/64
 ipv6 rip CCIE enable
!

interface Vlan79
 no ip address
 ipv6 address 2002:A00:A0A:4F::9/64
 ipv6 rip CCIE enable
!



SW4 IPv6 Address and RIPng Config:
!
interface Vlan99
 no ip address
 ipv6 address 2002:A00:A0A:63::9/64
 ipv6 rip CCIE enable

!

interface Vlan107
 no ip address
 ipv6 address 2002:A00:A0A:6B::A/64
 ipv6 rip CCIE enable
!


After checking neighbor-to-neighbor connectivity proceed to step 3.

Step 3
Configure tunnel and static routing between the sites.

R1 Config:
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 address 2002:A00:101::1/64
 tunnel source Loopback0
 tunnel mode ipv6ip 6to
4
!

!
! Since we only have two sites, we can use easy static routing like the one shown below:
!
ipv6 route 2002::/16 tunnel 0
!
ipv6 router rip CCIE
 redistribute static metric 1
!


SW4 Config:
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 address 2002:A00:A0A::A/64
 tunnel source Loopback0
 tunnel mode ipv6ip 6to4

!

ipv6 route 2002::/16 tunnel 0
!
ipv6 router rip CCIE
 redistribute static metric 1

!

Verification
Pic. 3 - Simple Ping Test.
Pic. 4 - Traceroute Test.

Sunday, January 27, 2013

Lab 210 - IPv6 over IPv4 Using IPv6IP Tunnel

Prerequisites: CCNP level skills.

Note!
If interfaces have not been configured with IPv6 addresses yet, use fc00:1:1::/64 as the network-ID and ::x, as a host ID (where x=router-ID).

Topology

Pic 1. IPv6 and IPv4 Topology Diagram.
Task 1
You no longer have to support other protocol while connecting the IPv6 networks in our topology (pic. 1). Reconfigure previous labs in such a way that the tunnel allows only IPv6 over IPv4 between R1 and SW4.

Solution

Task 1
You no longer have to support other protocol while connecting the IPv6 networks in our topology (pic. 1). Reconfigure previous labs in such a way that the tunnel allows only IPv6 over IPv4 between R1 and SW4.

R1 Config:
!
interface Tunnel0
 no ip address
 ipv6 address 2001:110::1/64
 ipv6 rip CCIE enable
 tunnel source Loopback0
 tunnel destination 10.0.10.10
 tunnel mode ipv6ip
!


SW4 Config:

!
interface Tunnel0
 no ip address
 ipv6 address 2001:110::10/64
 ipv6 rip CCIE enable
 tunnel source Loopback0
 tunnel destination 10.0.1.1
 tunnel mode ipv6ip

!

Verification:
SW4#show int tunnel0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.0.10.10 (Loopback0), destination 10.0.1.1
  Tunnel protocol/transport IPv6/IP


Saturday, January 26, 2013

Lab 209 - IPv6 Over IPv4 Using GRE Tunnel

Prerequisites: CCNP level skills.

Note!
If interfaces have not been configured with IPv6 addresses yet, use fc00:1:1::/64 as the network-ID and ::x, as a host ID (where x=router-ID).

Topology

Pic 1. IPv6 and IPv4 Topology Diagram.
Task 1
Configure IPv6 and IPv4 addresses, RIPng and EIGRP AS 1, according to the topology diagram (pic. 1 above). On R1 and SW4, advertise their loopback0 interfaces in EIGRP.

Task 2
Configure R1 and SW4 in such a way that IPv6 subnet in VLAN 215 can reach IPv6 subnets in VLANs 7, 9, 27, 79, and 99. Ensure that the tunnelling method can carry packets other than IPv6 (for instance IS-IS based on CLNS protocol). Tunnel should be based on the R1's and SW4's most stable interfaces. You can add two new IPv6 addresses to make the solution work.

Solution

Task 1
Configure IPv6 addresses, RIPng and EIGRP AS 1according to the topology diagram (pic. 1 above). On R1 and SW4, advertise their loopback0 interfaces in EIGRP.

R1 IPv4 and IPv6 Address Configuration:
!
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.0

!
interface FastEthernet0/0
 ip address 192.0.2.1 255.255.255.0
 speed 100
 full-duplex
!

interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 ipv6 address 2001:172:16:215::1/64
!


R5 IPv6 Address Configuration:
!
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 ipv6 address 2001:172:16:215::5/64
!


SW1 IPv6 Address Configuration:
!
!

interface Vlan7
 no ip address
 ipv6 address 2001:172:16:7::7/64

!
interface Vlan79
 no ip address
 ipv6 address 2001:172:16:79::7/64
!

interface Vlan107
 no ip address
 ipv6 address 2001:172:16:107::7/64
!

interface FastEthernet1/2
 no switchport
 no ip address
 duplex full
 speed 100
 ipv6 address 2001:172:16:27::7/64
!


SW2 IPv6 Address Configuration:
!
!
interface Vlan215
 no ip address
 ipv6 address 2001:172:16:215::8/64
!


SW3 IPv6 Address Configuration:
!
!
interface Vlan9
 no ip address
 ipv6 address 2001:172:16:9::9/64

!
interface Vlan79
 no ip address
 ipv6 address 2001:172:16:79::9/64
!

interface Vlan99
 no ip address
 ipv6 address 2001:172:16:99::9/64
!


SW4 IPV6 and IPv4 Address Configuration:
!
!

interface Loopback0
 ip address 10.0.10.10 255.255.255.0
!

interface Vlan107
 no ip address
 ipv6 address 2001:172:16:107::10/64

!
interface Vlan134
 ip address 192.0.2.10 255.255.255.0

!


Task 2
Configure R1 and SW4 in such a way that IPv6 subnet in VLAN 215 can reach IPv6 subnets in VLANs 7, 9, 27, 79, and 99. Ensure that the tunnelling method can carry packets other than IPv6 (for instance IS-IS based on CLNS protocol). Tunnel should be based on the R1's and SW4's most stable interfaces. You can add two new IPv6 addresses to make the solution work.

Step 1 - RIPng Between SW1, SW3, and SW4.
!
!
! SW1 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
!
interface Vlan7
 no ip address
 ipv6 address 2001:172:16:7::7/64
 ipv6 rip CCIE enable

!
interface Vlan79
 no ip address
 ipv6 address 2001:172:16:79::7/64
 ipv6 rip CCIE enable
!

interface Vlan107
 no ip address
 ipv6 address 2001:172:16:107::7/64
 ipv6 rip CCIE enable
!

interface FastEthernet1/2
 no switchport
 no ip address
 duplex full
 speed 100
 ipv6 address 2001:172:16:27::7/64
 ipv6 rip CCIE enable
!


Verification (perform on all remainging routers):
!
SW1#show ipv6 rip
RIP process "CCIE", port 521, multicast-group FF02::9, pid 194
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 8, trigger updates 4
  Interfaces:
    FastEthernet1/2
    Vlan107
    Vlan79
    Vlan7
  Redistribution:
    None
!



! SW3 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
!
interface Vlan9
 no ip address
 ipv6 address 2001:172:16:9::9/64
 ipv6 rip CCIE enable
!

interface Vlan79
 no ip address
 ipv6 address 2001:172:16:79::9/64
 ipv6 rip CCIE enable
!


interface Vlan99
 no ip address
 ipv6 address 2001:172:16:99::9/64
 ipv6 rip CCIE enable
!



! SW4 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
!
interface Vlan107
 no ip address
 ipv6 address 2001:172:16:107::10/64
 ipv6 rip CCIE enable
!


Verification:
Pic. Ping Connectivity Verification.


Step 2 - RIPng Between R1, R5, and SW2.
!
!
! R1 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 ipv6 address 2001:172:16:215::1/64
 ipv6 rip CCIE enable

!

!
! R5 Config:
!
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
interface FastEthernet0/1
 no ip address
 speed 100
 full-duplex
 ipv6 address 2001:172:16:215::5/64
 ipv6 rip CCIE enable
!


!
! SW2 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
interface Vlan215
 no ip address
 ipv6 address 2001:172:16:215::8/64
 ipv6 rip CCIE enable
!


Step 3 - EIGRP AS 1 Config:
!
!
! R1 Config:
!
router eigrp 1
 network 10.0.1.1 0.0.0.0
 network 192.0.2.1 0.0.0.0
 no auto-summary

!

!
! SW4 Config:
!
router eigrp 1
 network 10.0.10.10 0.0.0.0
 network 192.0.2.10 0.0.0.0
 no auto-summary

!

Verification:
Pic. 3 - EIGRP Adjacency.

Pic. 4 - Ping between Loopback (for tunnel puporses).

Step 4 - GRE Tunnel Configuration to enable IPv6 over IPv4
!
!
! R1 Config:
!
interface Tunnel0
 no ip address
 ipv6 address 2001:110::1/64
 ipv6 rip CCIE enable
 tunnel source Loopback0
 tunnel destination 10.0.10.10

!


!
!
! SW4 Config:
!
!
interface Tunnel0
 no ip address
 ipv6 address 2001:110::10/64
 ipv6 rip CCIE enable
 tunnel source Loopback0
 tunnel destination 10.0.1.1

!

Verification:
Pic. 5 - Ping Connectivity Test.

Wednesday, November 7, 2012

Lab 208 - IPv6 NAT-PT

Prerequisites: CCNP level skills.

Note!
If interfaces have not been configured with IPv6 addresses yet, use fc00:1:1::/64 as the network-ID and ::x, as a host ID (where x=router-ID).

Topology

Pic 1. IPv6 Topology Diagram.

Task 1
Vlan 113 runs IPv4 protocol (203.0.113.0/24). Configure R3 in such a way that 
R2 should ping 2001::CB00:71FE to reach 203.0.113.254 address (BB1).
You are allowed to use one static route on R2 to accomplish the goal.

Solution

Task 1
Vlan 113 runs IPv4 protocol (203.0.113.0/24). Configure R3 in such a way that 
R2 should ping 2001::CB00:71FE to reach 203.0.113.254 address (BB1).
You are allowed to use one static route on R2 to accomplish the goal.

R2 Config:
!
ipv6 route 2001::/96 FC00:1:1:20::3
!

R3 Config:
!
interface Serial1/0
 ipv6 address FC00:1:1:20::3/64
 ipv6 nat
 ipv6 ospf 1 area 13
!
interface FastEthernet0/0
 ip address 203.0.113.3 255.255.255.0
 speed 100
 full-duplex
 ipv6 nat
!
!
ipv6 nat v6v4 source FC00:1:1:20::2 203.0.113.2
ipv6 nat v4v6 source 203.0.113.254 2001::CB00:71FE
!
ipv6 nat prefix 2001::/96
!

Verification:
Pic. 2 - Ping Test from R2.


Pic. 3 - IPv6 NAT Table.

Lab 207 - IPv6 Access Control List

Prerequisites: CCNP level skills.

Note!
If interfaces have not been configured with IPv6 addresses yet, use fc00:1:1::/64 as the network-ID and ::x, as a host ID (where x=router-ID).

Topology

Pic 1. IPv6 Topology Diagram.

Task 1
Enable HTTP service in R3. Check if Vlan 27 can access the service.

Task 2
Configure filtering in R3 blocking access to HTTP server if the packets are sourced by Vlan 27. All remaining IPv6 networks should be able to access this service.

Solution

Task 1
Enable HTTP service in R3. Check if Vlan 27 can access the service.

R3 Config:
!
ip http server
!

Verification:
Pic. 2 - HTTP Access from Vlan 27.

Task 2
Configure filtering in R3 blocking access to HTTP server if the packets are sourced by Vlan 27. All remaining IPv6 networks should be able to access this service.

R3 Config:
!
ipv6 access-list VLAN27_BLOCK_HTTP
 deny tcp FC00:1:1:1B::/64 any eq www
 permit ipv6 any any
!
interface Serial1/0
 ipv6 address FC00:1:1:20::3/64
 ipv6 traffic-filter VLAN27_BLOCK_HTTP in
 ipv6 ospf 1 area 13
 serial restart-delay 0
!

Verification:
Pic. 3 - HTTP Access from Vlan 27.

Pic. 4 - HTTP Access from R1.


Saturday, November 3, 2012

Lab 206 - IPv6 Protocol Redistribution

Prerequisites: CCNP level skills.

Note!
If interfaces have not been configured with IPv6 addresses yet, use fc00:1:1::/64 as the network-ID and ::x, as a host ID (where x=router-ID).

Topology

Pic1. IPv6 Topology Diagram.

Task 1
Enable OSPFv3 Area 215 on R1's Fa0/1 interface.
Enable RIPng protocol between R1 and R2. R1 should run RIPng on its Fa0/0 and Se0/1 interface.
R2 should run RIPng on its Se0/1 interface.

Task 2
Enable EIGRPv6 between R2 and SW1. R2 should be running EIGRPv6 on its Fa0/0 interface, and SW1 on Vlan 7, Vlan 27, Vlan 79, and Vlan 107.

Task 3
Ensure IPv6 connectivity between all three routing domains (RIPng, EIGRPv6 and OSPFv3).

Solution

Task 1
Enable OSPFv3 Area 215 on R1's Fa0/1 interface.
Enable RIPng protocol between R1 and R2R1 should run RIPng on its Fa0/0 and Se0/1 interface.
R2 should run RIPng on its Se0/1 interface.

R1 Config:
!
interface FastEthernet0/0
 ipv6 address FC00:1:1:86::1/64
 ipv6 rip 12 enable
!
interface FastEthernet0/1
 ipv6 address FC00:1:1:D7::1/64
 ipv6 ospf 1 area 215
!
interface Serial0/1
 ipv6 address FC00:1:1:C::1/64
 ipv6 rip 12 enable
!

R2 Config:
!
interface Serial0/1
 ipv6 address FC00:1:1:C::2/64
 ipv6 rip 12 enable
!

Task 2
Enable EIGRPv6 between R2 and SW1R2 should be running EIGRPv6 on its Fa0/0 interface, and SW1 on Vlan 7, Vlan 27, Vlan 79, and Vlan 107 interfaces.

R2 Config:
!
ipv6 router eigrp 1
 no shutdown
!
interface FastEthernet0/0
 ip address 172.16.27.2 255.255.255.0
 speed 100
 full-duplex
 ipv6 address FC00:1:1:1B::2/64
 ipv6 eigrp 1
!

SW1 Config:
!
ipv6 unicast-routing
!
ipv6 router eigrp 1
 no shutdown
!
interface Vlan7
 ipv6 address FC00:1:1:7::7/64
 ipv6 eigrp 1
!
interface Vlan27
 ipv6 address FC00:1:1:1B::7/64
 ipv6 eigrp 1
!
interface Vlan79
 ipv6 address FC00:1:1:4F::7/64
 ipv6 eigrp 1
!
interface Vlan107
 ipv6 address FC00:1:1:6B::7/64
 ipv6 eigrp 1
!

Task 3
Ensure IPv6 connectivity between all three routing domains (RIPng, EIGRPv6 and OSPFv3).

R2 Config:
!
ipv6 router eigrp 1
 no shutdown
 redistribute ospf 1 metric 1 1 1 1 1 include-connected
 redistribute rip 12 metric 1 1 1 1 1 include-connected
!
ipv6 router ospf 1
 log-adjacency-changes
 redistribute eigrp 1 metric 30 include-connected
 redistribute rip 12 metric 30 include-connected
!
ipv6 router rip 12
 redistribute ospf 1 metric 5 include-connected
 redistribute eigrp 1 metric 5 include-connected
!

Verification:
On R1, R2, R3, R4, R5, R6, SW1, SW2 the following ping script (works):

foreach address {
FC00:1:1:7::7
FC00:1:1:1B::7
FC00:1:1:4F::7
FC00:1:1:6B::7
FC00:1:1:1B::2
FC00:1:1:C::2
FC00:1:1:20::2
FC00:1:1:22:8000::1
FC00:1:1:22:9000::1
FC00:1:1:22:A000::1
FC00:1:1:22:B000::1
FC00:1:1:86::1
FC00:1:1:D7::1
FC00:1:1:C::1
FC00:1:1:20::3
FC00:1:1:2D::4
FC00::4
FC00:1:1:45::4
FC00:A:A:A::4
FC00:1:1:D7::5
FC00:1:1:45::5
FC00::6
FC00:1:1:2D::6
FC00:A:A:A::6
FC00:1:1:D7::8
} { ping $address }

How to use the script:
R1#tclsh
here paste the script and hit ENTER.

Then:
R1(tcl)#tclquit

Thursday, November 1, 2012

Lab 205 - OSPFv3 Prefix Summarization

Prerequisites: CCNP level skills.

Topology

Notice!
IPv6 addresses have changed. Follow the below topology diagram and tasks to accomplish the goals.

Pic1. IPv6 Topology Diagram.

Task 1
Configure IPv6 addresses on Serial1/0 of R2 and R3. Use router's number as the IPv6 Host ID and Network ID as per topology diagram.

Task 2
Enable OSPFv3 between R2 and R3 using their point-to-point link. Use Area 13.

Task 3
In R2 Create four loopback interfaces with the following IPv6 addresses:

  • Loopback1: FC00:1:1:22:8000::1/80
  • Loopback2: FC00:1:1:22:9000::1/80
  • Loopback3: FC00:1:1:22:A000::1/80
  • Loopback4: FC00:1:1:22:B000::1/80
Task 4
Enable OSPFv3 Area 13 on the above loopbacks. Ensure that the rest of OSPFv3 domain receive a summary route representing all the loopbacks advertised into OSPF in task 3.

Solution

Task 1
Configure IPv6 addresses on Serial1/0 of R2 and R3. Use router's number as the IPv6 host ID and Network ID as per topology diagram.

R2 Config:
!
interface Serial1/0
 ipv6 address FC00:1:1:20::2/64
!

R3 Config:
!
interface Serial1/0
 ipv6 address FC00:1:1:20::3/64
!

Task 2
Enable OSPFv3 between R2 and R3 using their point-to-point link. Use Area 13.

R2, R3 Config:
!
interface Serial1/0
 ipv6 ospf 1 area 13
!

Task 3
In R2 Create four loopback interfaces with the following IPv6 addresses:
  • Loopback1: FC00:1:1:22:8000::1/80
  • Loopback2: FC00:1:1:22:9000::1/80
  • Loopback3: FC00:1:1:22:A000::1/80
  • Loopback4: FC00:1:1:22:B000::1/80
R2 Config:
!
interface Loopback1
 no ip address
 ipv6 address FC00:1:1:22:8000::1/80
 ipv6 ospf network point-to-point
!
interface Loopback2
 no ip address
 ipv6 address FC00:1:1:22:9000::1/80
 ipv6 ospf network point-to-point
!         
interface Loopback3
 no ip address
 ipv6 address FC00:1:1:22:A000::1/80
 ipv6 ospf network point-to-point
!         
interface Loopback4
 no ip address
 ipv6 address FC00:1:1:22:B000::1/80
 ipv6 ospf network point-to-point
!         

Task 4
Enable OSPFv3 Area 13 on the above loopbacks. Ensure that the rest of OSPFv3 domain receive a summary route representing all the loopbacks advertised into OSPF in task 3.

R2 Config:
!
interface Loopback1
 ipv6 ospf 1 area 13
!
interface Loopback2
 ipv6 ospf 1 area 13
!         
interface Loopback3
 ipv6 ospf 1 area 13
!         
interface Loopback4
 ipv6 ospf 1 area 13
!         

Verification:
Pic. 2 - R2 and R3 OSPFv3 Neighbors.



Pic. 3 - R4 Receives the Loopback1-4 Network Prefixes.

R3 Config:
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 13 range FC00:1:1:22:8000::/66
!

Verification:
Pic. 4 - R4 IPv6 Connectivity.

Tuesday, October 23, 2012

Lab 204 - OSPFv3 Virtual Link

Prerequisites: CCNP level skills.

Topology

Notice!
IPv6 addresses have changed. Follow the below topology diagram and tasks to accomplish the goals.

Pic1. IPv6 Topology Diagram.

Task 1
Configure OSPFv3 area 45 between R4 and R5 on their point-to-point link. IPv6 addresses should follow the pattern you have used in previous labs. Configure OSPFv3 area 215 between R5 and SW2. Ensure full IPv6 connectivity within the routing domain.

Solution

Task 1
Configure OSPFv3 area 45 between R4 and R5 on their point-to-point link. IPv6 addresses should follow the pattern you have used in previous labs. Configure OSPFv3 area 215 between R5 and SW2. Ensure full IPv6 connectivity within the routing domain.

R4 Config:
!
ipv6 router ospf 1
 router-id 4.4.4.4
 area 45 virtual-link 5.5.5.5
!
interface Serial0/1
 ip address 172.16.45.4 255.255.255.0
 ipv6 address FC00:1:1:45::4/64
 ipv6 ospf 1 area 45
 clock rate 2000000
!

R5 Config:
!
ipv6 unicast-routing
!
ipv6 router ospf 1
 router-id 5.5.5.5
 area 45 virtual-link 4.4.4.4
!
interface Serial0/1
 ip address 172.16.45.5 255.255.255.0
 ipv6 address FC00:1:1:45::5/64
 ipv6 ospf 1 area 45
 clock rate 2000000
!
interface FastEthernet0/1
 speed 100
 full-duplex
 ipv6 address FC00:1:1:D7::5/64
 ipv6 ospf 1 area 215
!

SW2 Config:
!
ipv6 unicast-routing
!
ipv6 router ospf 1
 router-id 10.10.10.10
!
interface Vlan215
 ip address 172.16.215.8 255.255.255.0
 ipv6 address FC00:1:1:D7::8/64
 ipv6 address FC00:1:1:D7::10/64
 ipv6 ospf 1 area 215
!

Verification:

Pic. 2 - SW2's Routing Table.

Pic. 3 - Virtual Link Between R4 and R5.

Lab 203 - OSPFv3 Path Influencing

Prerequisites: CCNP level skills.

Topology

Notice!
IPv6 addresses have changed. Follow the below topology diagram and tasks to accomplish the goals.

Pic1. IPv6 Topology Diagram.

Task 1
Modify previous lab's configuration of OSPFv3 between R3, R4, and R6 as shown in Pic. 2:

Pic. 2



Task 2
Enable OSPFv3 between R4 and R6. Broadcast network should use addresses according to the topology diagram with ::x as their host portion, where 'x' is the router number.

Task 3
Ensure that R3 uses R6 as its primary gateway towards FC00:1:1:2D::/64. In case of R6 being unavailable, R3 is to choose R4 to reach the network in question. Configuration should be done on R3.

Solution

Task 1
Modify previous lab's configuration of OSPFv3 between R3R4, and R6 as shown in Pic. 2.

R3 Config:
!
interface Serial0/1
 encapsulation frame-relay
 ipv6 address FE80::3 link-local
 ipv6 address FC00::3/64
 ipv6 ospf network point-to-multipoint
 ipv6 ospf 1 area 0
 clock rate 2000000
 frame-relay map ipv6 FC00::4 314 broadcast
 frame-relay map ipv6 FC00::6 316 broadcast
 frame-relay map ipv6 FE80::6 316
 frame-relay map ipv6 FE80::4 314
 no frame-relay inverse-arp
!

R4 Config:
!

interface Serial0/0
 encapsulation frame-relay
 ipv6 address FE80::4 link-local
 ipv6 address FC00::4/64
 ipv6 ospf network point-to-multipoint
 ipv6 ospf 1 area 0
 clock rate 2000000
 frame-relay map ipv6 FE80::3 413 broadcast
 frame-relay map ipv6 FC00::3 413
 no frame-relay inverse-arp
!

R6 Config:
!
interface Serial0/0
 encapsulation frame-relay
 ipv6 address FE80::6 link-local
 ipv6 address FC00::6/64
 ipv6 ospf network point-to-multipoint
 ipv6 ospf 1 area 0
 clock rate 2000000
 frame-relay map ipv6 FE80::3 613 broadcast
 frame-relay map ipv6 FC00::3 613
 no frame-relay inverse-arp
!

Task 2
Enable OSPFv3 between R4 and R6. Broadcast network should use addresses according to the topology diagram with ::x as their host portion, where 'x' is the router number.

R4 Config:
!
interface FastEthernet0/0
 speed 100
 full-duplex
 ipv6 address FC00:1:1:2D::4/64
 ipv6 ospf 1 area 0
!

R6 Config:
!
interface FastEthernet0/1
 ip address 172.16.46.6 255.255.255.0
 speed 100
 full-duplex
 ipv6 address FC00:1:1:2D::6/64
 ipv6 ospf 1 area 0
!


Verfication:
Pic. 3 - R4 and R6 OSPFv6 Neighbors.


Task 3
Ensure that R3 uses R6 as its primary gateway towards FC00:1:1:2D::/64. In case of R6 being unavailable, R3 is to choose R4 to reach the network in question. Configuration should be done on R3.

Before path influencing:

Pic. 4.

R3 Config:
!
interface Serial0/1
  ipv6 ospf neighbor FE80::4 cost 65
!

Routing table after the configuration change:

Pic. 5.