Showing posts with label EIGRP. Show all posts
Showing posts with label EIGRP. Show all posts

Wednesday, March 23, 2011

Lab 62 - EIGRP Other Features

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
Configure EIGRP routers so that the maximum hop count cannot exceed 12 routers.

Task 2
Configure EIGRP routers so that the EIGRP warning messages are sent at 30 second intervals and disable EIGRP neighbor change messages.

Lab Solution

Task1
Configure EIGRP routers so that the maximum hop count cannot exceed 12 routers.

On All Routers:
!
router eigrp 1
  metric maximum-hops 12
!

Task 2
Configure EIGRP routers so that the EIGRP warning messages are sent at 30 second intervals and disable EIGRP neighbor change messages.

On All Routers:

!
router eigrp 1
 eigrp log-neighbor-warnings 30
 no eigrp log-neighbor-changes 
!

Lab 61 - EIGRP Timers

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
Configure R1 to send hello towards R3 every 2 seconds on S0/1 interface. THe hold interval should be 3 times the hello timer. Do not change timers on R3.

Task 2
Configure EIGRP so that the routers should respond to EIGRP Query packet within 60 seconds before the neighbor is declared SIA.

Task 3
Configure EIGRP so that the routers will hold known routes for NFS-capable neighbor for 2 minutes during switch-over operation.

Lab Solution

Task1
Configure R1 to send hello towards R3 every 2 seconds on S0/1 interface. THe hold interval should be 3 times the hello timer. Do not change timers on R3.

R1 Configuration:
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 ip hello-interval eigrp 1 2
 ip hold-time eigrp 1 6
!

Note!
In EIGRP the hello and hold interval do not have to match between neighbors (for consistency sake they should be set identically though).

Task 2
Configure EIGRP so that the routers should respond to EIGRP Query packet within 60 seconds before the neighbor is declared SIA.

On All Routers:
!
router eigrp 1
  timers active-time 1
!

Task 3
Configure EIGRP so that the routers will hold known routes for NFS-capable neighbor for 2 minutes during switch-over operation.
On All Routers:

!
router eigrp 1
  timers nsf route-hold 120
!

Verification:
Pic 2 - NFS Route-Hold Timer.
Notice!
NFS route-hold timer ranges from 20-300 seconds. The default is 240 sec. and can be displayed using 'show ip protocols' command.

Tuesday, March 22, 2011

Lab 60 - EIGRP Unicast Communication

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Note!
EIGRP uses 224.0.0.10 address to send most the packets. It can use unicast instead. In such situations, all neighbors must be configured to use unicast.

Task1
Configure R1 to use unicast instead of multicast while exchanging EIGRP packets.

Lab Solution

Task1
Configure R1 to use unicast instead of multicast while exchanging EIGRP packets.

R1 Configuration:
!
router eigrp 1
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
 neighbor 10.1.124.4 FastEthernet1/0
 neighbor 10.1.124.2 FastEthernet1/0
!

Notice!
At this moment both routers: R2 and R4, are no longer considered neighbors since they still use multicast for EIGRP packets.

Pic. 2 - R1's EIGRP Neighbors.
R2 Configuration:
!
router eigrp 1
 network 10.1.123.2 0.0.0.0
 network 10.1.124.2 0.0.0.0
 network 172.16.102.2 0.0.0.0
 no auto-summary
 neighbor 10.1.124.4 FastEthernet1/0
 neighbor 10.1.124.1 FastEthernet1/0
!

R4 Configuration:
!
router eigrp 1
 passive-interface Loopback0
 passive-interface Loopback1
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 no auto-summary
 neighbor 10.1.124.2 FastEthernet1/0
 neighbor 10.1.124.1 FastEthernet1/0
!


Note!
Loopbacks are configured in passive-interface mode so the 'debug ip packet detail' does not send EIGRP packets out these interfaces.

Verification:
Pic. 3 - R4's EIGRP Neighbors.

Debug ip packet detail proves that unicast is used while exchanging EIGRP packets.
Pic. 4 - Debug IP Packets Detail.

Lab 59 - EIGRP Router ID

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Note!
EIGRP adds the router ID to the external prefixes. In case the advertising router receives them back with its own ID, the are being rejected. This serves as the loop prevention mechanism.

Task1
Configure R3 with the router ID = 3.3.3.3. Advertise Loopback0 (172.16.103.0/24) and Loopback1 (172.16.133.0/24) as EIGRP external prefixes.

Task 2
Configure R4 to reject the EIGRP external prefixes advertised by R3. Do not use any filtering commands such as ACLs, route-maps, distribute-list or offset-list.

Lab Solution


Task1
Configure R3 with the router ID = 3.3.3.3. Advertise Loopback0 (172.16.103.0/24) and Loopback1 (172.16.133.0/24) as EIGRP external prefixes.


R3 Configuration:

!
route-map CONN_TO_EIGRP permit 10
 match interface Loopback0 Loopback1
!
router eigrp 1
 redistribute connected route-map CONN_TO_EIGRP
 network 10.1.13.3 0.0.0.0
 network 10.1.123.3 0.0.0.0
 no auto-summary
 eigrp router-id 3.3.3.3
!


Verification:

Pic. 4 - R4's Routing Table.
Task 2

Configure R4 to reject the EIGRP external prefixes advertised by R3. Do not use any filtering commands such as ACLs, route-maps, distribute-list or offset-list.
Pic. 3 - R3's Router ID Check on R4.

R4 Configuration:
!
router eigrp 1
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 no auto-summary
 eigrp router-id 3.3.3.3
!

Verification:
Pic. 4 - R4's Routing Table.
Notice!
R4 rejects EX prefixes this time since it has the SAME EIGRP router ID.

Monday, March 21, 2011

Lab 58 - EIGRP Authentication

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
Configure EIGRP authentication on Frame-Relay link with the seamless key rotation (no interruption in the service). Below are the parameters to be used:
  • key 1 uses string 'CISCO1' and should be sent between 12:00:00 on Jan 1st 2011 and 12:10:00 on April 30th.
  • key 1 should be accepted 5 minutes past its sending time.
  • key 2 uses string 'CISCO2' and should be sent starting 12:00:00 on April 30th till the end of 2011 and valid forever.
Lab Solution

Task1
Configure EIGRP authentication on Frame-Relay link with the seamless key rotation (no interruption in the service). Below are the parameters to be used:
  • key 1 uses string 'CISCO1' and should be sent between 12:00:00 on Jan 1st 2011 and 12:10:00 on April 30th.
  • key 1 should be accepted 5 minutes past its sending time.
  • key 2 uses string 'CISCO2' and should be sent starting 12:00:00 on April 30th till the end of 2011 and valid forever.
Notice!
For the key rotation to work correctly, NTP service must be in use synchronizing the time on all routers. Since, I do not have NTP service enabled, I'll set up the clock manually.

Pic 2 - Date on the Routers.


R1, R2 and R3 configuration
!
key chain EIGRP_KEYS
 key 1
   key-string CISCO1
   accept-lifetime 12:00:00 Jan 1 2011 12:15:00 Apr 30 2011
   send-lifetime 12:00:00 Jan 1 2011 12:10:00 Apr 30 2011
 key 2
   key-string CISCO2
   accept-lifetime 12:00:00 Apr 30 2011 infinite
   send-lifetime 12:00:00 Apr 30 2011 infinite
!
interface Serial0/0
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP_KEYS
!

Verification:
Pic. 3 - Key Chain.
Pic. 4 - R3 EIGRP Neighbors.

Lab 57 - Frame-Relay Packet Pacing

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
Ensure that EIGRP on the Frame-Relay links is guaranteed 308 Kbps.

Lab Solution

Task1
Ensure that EIGRP on the Frame-Relay links is guaranteed 308 Kbps.

Pic. 2 - Current Bandwidth on S0/0 Links.

Notice!

By default EIGRP can consume up to 50% of the available bandwidth.

Percent = (308 * 100) / 1544 = 19.94 (circa 20% of the available band)

R1, R2 and R3 Configuration:
!
interface serial0/0
ip bandwidth-percent eigrp 1 20 
!

Lab 56 - EIGRP Traffic Engineering with the Delay

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
Configure R1 for equal cost load balancing towards R3's Loopback interfaces. R1 should all three links S0/0, S0/1 and F1/0. You can use any K-values to accomplish the goal.

Lab Solution

Task1
Configure R1 for equal cost load balancing towards R3's Loopback interfaces. R1 should all three links S0/0, S0/1 and F1/0. You can use any K-values to accomplish the goal.

Notice!
The simplest solution is to take the awkward 'bandwidth' parameter out of the equasion and manipulate the delay. This way the formula is going to look like this:

Metric = (Sum_of_all_Delays_in_microsec * 256) / 10

On All Routers:
!
router eigrp 1
 metric weight 0 0 0 1 0 0
!

Verification: All routers use Delay only (like R1 below)


Pic. 2 - K-values Factored In.

Pic. 3 - R1's EIGRP Topology (172.16.103.0)
Notice!
R2's Advertised Distance = FD; it's not a feasible successor and cannot be taken into account as the neighbor for traffic sharing with the current settings.

R1 Configuration:
!
interface Serial0/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 delay 2010
 serial restart-delay 0
 frame-relay map ip 10.1.123.2 103
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 delay 2010
 serial restart-delay 0
!

Verification:
Pic. 4 - R1's Routing Table.

Sunday, March 20, 2011

Lab 55 - EIGRP Unequal Cost Load Balancing

Prerequisites: CCNP level skills.

Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
R1 has currently two equal cost paths towards R3's Loopback interfaces. Ensure that R1 uses all paths available using unequal cost load balancing.

Lab Solution

Task1
R1 has currently two equal cost paths towards R3's Loopback interfaces. Ensure that R1 uses all paths available using unequal cost load balancing.

Notice!
The task does not stipulate how load balancing should work.

First, check in R1's routing table towards the subnets in question.

Pic. 2 - R1's Routing Table.
Currently, R2 is not listed as a gateway towards the subnets in question. EIGRP Topology will reveal the AD R2 advertises.

Pic. 3 - R1's EIGRP Topology Table.

In order for R2 (10.1.124.2) to be used as the gateway with unequal cost LB, it must be a feasible successor. Now, It is not since its AD equals the best FD. Using default K-values the formula to calculate the metric can be simplified to the following:

Metric = (Bandwidth + Delay) * 256
where:
Bandwidth = 10 to the 7th power / the_slowest_link_in_the_path (in Kbps)
Delay = sum_of_all_delays_in_the_path / 10

Based on the output in the pic. 3 I must modify either the bandwidth or delay to make R2 a feasible successor. The latter is easier.

R1 Configuration:
!
interface Serial0/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 delay 3000
 serial restart-delay 0
 frame-relay map ip 10.1.123.2 103
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 delay 3000
 serial restart-delay 0
!

Note!
Clear ip eigrp neighbor command is required to refresh the topology table.

R2 becomes the successor with R1's both links as two feasible successors.

Pic. 4 - R1's Topology Table (output truncated).

FD = 2300416
AD = 2553856

Variance 2 will do.

R1 Configuration:
!
router eigrp 1
 variance 2
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
!


Verification:
Pic. 5 - R1's Routing Table.

Lab 54 - EIGRP Default Route Advertisement

Prerequisites: CCNP level skills.


Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task1
Make R4 the gateway of the last resort for all routers. Use the following methods (always remove the previous one before proceeding to the new one):
  1. Using summary route.
  2. Using 'network 0.0.0.0'.
  3. Using the default route redistribution.
  4. Using 'ip default-network' statement.
Lab Solution

Task 1
Make R4 the gateway of the last resort for all routers. Use the following methods (always remove the previous one before proceeding to the new one):

Method 1 - Summary Route

R4 Configuration:
!
interface FastEthernet1/0
 ip address 10.1.124.4 255.255.255.0
 ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5
!

Method 2 - Network 0.0.0.0

R4 Configuration:
!
ip route 0.0.0.0 0.0.0.0 null0
!
router eigrp 1
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 network 0.0.0.0
 no auto-summary
!

Method 3 - Default Route Redistribution

R4 Configuration:
!
ip route 0.0.0.0 0.0.0.0 Null0
!
router eigrp 1
 redistribute static
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 no auto-summary
!

Method 4 - IP Default-Network

Note!
This method comes from IGRP. It assumes that the router will use the default network rather than default route (0.0.0.0). The method has two stipulations:
  • the network advertised as the gateway of last resort must belong to a class A, B, or C network
  • the network advertised as the gateway of last resort must not be directly connected to the advertising router (must be learned)
In order to overcome these stipulations the following will work:

R4 Configuration:
!
ip default-network 172.16.104.0
!

Verification:
This step results in creating the following entry:

Pic. 2 - R4's Routing Table.
Since the classful entry now appears in the routing table, the following configuration will create default network on R4. (the network of the last resort).
R4 Configuration:
!
ip default-network 172.16.0.0
!

The above command replaces the previous one and results with:

Pic. 3 -  R4's Routing Table.

The last step is to redistribute this static entry into EIGRP in order to advertise the gateway of the last resort to R4's EIGRP neighbors.

R4 Configuration:
!
router eigrp 1
 redistribute static
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 no auto-summary
!

This results in advertising default network (*)
Pic. 4 - R1's Routing Table.

Saturday, March 19, 2011

Lab 53 - EIGRP Filtering with Stub Routing and Leak Map

Prerequisites: CCNP level skills.

Note!
Use the configuration from the lab 52 but REMOVE 'eigrp stub' on R4.

EIGRP filtering can use:
  1. Standard ACL.
  2. Extended ACL.
  3. Prefix-List.
  4. Route-Map.
  5. Administrative Distance.
  6. Passive-Interface.
  7. Offset-List.
  8. Stub Routing.
  9. Selective Stub Routing (stub routing with leak map).
Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Using the lab 52 config, remove eigrp stub command on R4.

Task 2
Configure R1 and R2 as EIGRP stub routers. Use default options (connected and summary).

Task 3
Keeping R1 and R2 EIGRP stub routers allow R1 to advertise 10.0.44.0/24.

Task 4
Keeping R1 and R2 EIGRP stub routers allow R2 to advertise 10.0.4.0/24.

Lab Solution

Task 1
Using the lab 52 config, remove eigrp stub command on R4.

R4 Configuration:
!
R4(config-router)#no eigrp stub
R4(config-router)#
!

Task 2
Configure R1 and R2 as EIGRP stub routers. Use default options (connected and summary).

R1 Configuration:
!
router eigrp 1
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
 eigrp stub connected summary
!

R2 Configuration:
!
router eigrp 1
 network 10.1.123.2 0.0.0.0
 network 10.1.124.2 0.0.0.0
 network 172.16.102.2 0.0.0.0
 no auto-summary
 eigrp stub connected summary
!

Verification:
Pic. 2 - R3 Routing Table.
Notice!
R3 does not receive R4's prefixes because R1 and R2 filters them out (only connected and summary routes can be advertised by R1 and R2).

Task 3
Keeping R1 and R2 EIGRP stub routers allow R1 to advertise 10.0.44.0/24.

R1 Configuration:
!
ip prefix-list R4_L3 seq 5 permit 10.0.44.0/24
!
route-map LEAK permit 10
 match ip address prefix-list R4_L3
!
router eigrp 1
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
 eigrp stub connected summary leak-map LEAK
!

Verification:
Pic. 3 - R3's Routing Table.
Notice!
R1 unsuppressed 10.0.44.0/24. It takes a moment longer to advertise the same prefix over S0/0 as it is a slow link. Also, while using 'leak-map' the defaults (connected and summary) are not added unless manually typed in.

Task 4
Keeping R1 and R2 EIGRP stub routers allow R2 to advertise 10.0.4.0/24.

R2 Configuration:
!
ip prefix-list R4_L2 seq 5 permit 10.0.4.0/24
!
route-map LEAK permit 10
 match ip address prefix-list R4_L2
!
router eigrp 1
 network 10.1.123.2 0.0.0.0
 network 10.1.124.2 0.0.0.0
 network 172.16.102.2 0.0.0.0
 no auto-summary
 eigrp stub connected summary leak-map LEAK
!

Verification:
Pic. 4 - R3's Routing Table.

Lab 52 - EIGRP Filtering with Stub Routing

Prerequisites: CCNP level skills.

Note!
Use the basic EIGRP configuration (Lab 45 Task 1) in the labs 45-53.

EIGRP filtering can use:
  1. Standard ACL.
  2. Extended ACL.
  3. Prefix-List.
  4. Route-Map.
  5. Administrative Distance.
  6. Passive-Interface.
  7. Offset-List.
  8. Stub Routing.
  9. Selective Stub Routing (stub routing with leak map).
Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Add two more loopbacks on R4 with the respective addresses:
Loopback 2: 10.0.4.4/24
Loopback 3: 10.0.44.4/24

Advertise them as External prefixes.

Task 2
Configure R4 so that it can advertise only connected and summary routes in EIGRP. It should not be queried by R1 and/or R2 if they lose any EIGRP prefix.

Lab Solution

Task 1
Add two more loopbacks on R4 with the respective addresses:
Loopback 2: 10.0.4.4/24
Loopback 3: 10.0.44.4/24

Advertise them as External prefixes.

R4 Configuration:
!
interface Loopback2
 ip address 10.0.4.4 255.255.255.0
!
interface Loopback3
 ip address 10.0.44.4 255.255.255.0
!
route-map CONNECTED permit 10
 match interface Loopback2 Loopback3
!
router eigrp 1
 redistribute connected route-map CONNECTED
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
!

Verification:
Pic. 2 - R3 Receives External Prefixes.
Task 2
Configure R4 so that it can advertise only connected and summary routes in EIGRP. It should not be queried by R1 and/or R2 if they lose any EIGRP prefix.

R4 Configuration:
!
router eigrp 1
 redistribute connected route-map CONNECTED
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 eigrp stub connected summary
!

Pic. 3 - EIGRP Stub Options (the defaults in yellow).

Verification:
Pic. 4 - R1 Sees R4 as the Stub Router.

R4 can now only advertise directly connected networks/subnets (these enabled in EIGRP) as well as summary route (the defaults in 'stub' command). Also R1 and R2 are not going to send EIGRP Query packets upon losing their EIGRP prefixes.

Note!
Even though R4 is a 'stub' router allowing connected and summary routes, it does advertise EIGRP prefixes that have been redistributed. They are still connected enabled (redistributed) in EIGRP. 

Pic. 5 - R3's External Prefixes.

Friday, March 18, 2011

Lab 51 - EIGRP Filtering with Offset-List

Prerequisites: CCNP level skills.

Note!
Use the basic EIGRP configuration (Lab 45 Task 1) in the labs 45-53.

EIGRP filtering can use:
  1. Standard ACL.
  2. Extended ACL.
  3. Prefix-List.
  4. Route-Map.
  5. Administrative Distance.
  6. Passive-Interface.
  7. Offset-List.
  8. Stub Routing.
  9. Selective Stub Routing (stub routing with leak map).
Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Change the metric on R1 to prefer the next-hop 10.1.13.3 towards 172.16.103.0/24 and the next-hop 10.1.123.3 towards 172.16.133.0/24. Do not use a route-map to accomplish this.

Lab Solution


Task 1
Change the metric on R1 to prefer the next-hop 10.1.13.3 towards 172.16.103.0/24 and the next-hop 10.1.123.3 towards 172.16.133.0/24. Do not use a route-map to accomplish this.
Pic. 2 - The Current R1's Routing Table
(before a change).

Since there are three paths (also via F1/0) it is good to look at the AD of R2 which also must advertise these two prefixes. A proper adjustment must include R2 as well.

Pic. 3 - EIGRP Topology for 172.16.103.0/24 on R1.
Notice!
R2's AD equals FD through R1 (both S0/0 and S0/0). If I add the offset to the metric received from R1, R2 becomes the best path.


R1 Configuration:
!
access-list 1 permit 172.16.103.0
access-list 2 permit 172.16.133.0
access-list 3 permit 172.16.133.0
access-list 3 permit 172.16.103.0
!
router eigrp 1
 offset-list 1 in 100 Serial0/0
 offset-list 2 in 100 Serial0/1
 offset-list 3 in 300 FastEthernet1/0
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
!

The configuration accomplishes the goal.

Pic. 4 - The Current R1's Routing Table
(after a change).

Lab 50 - EIGRP Filtering with Passive-Interface

Prerequisites: CCNP level skills.

Note!
Use the basic EIGRP configuration (Lab 45 Task 1) in the labs 45-53.

EIGRP filtering can use:
  1. Standard ACL.
  2. Extended ACL.
  3. Prefix-List.
  4. Route-Map.
  5. Administrative Distance.
  6. Passive-Interface.
  7. Offset-List.
  8. Stub Routing.
  9. Selective Stub Routing (stub routing with leak map).
Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Configure R1 so that it receives prefixes on its S0/0 interface but not S0/1. Do not use any access-list, distribute-list or route-map, or distance command. R1 should still advertise 10.1.13.0/24.

Lab Solution

Task 1
Configure R1 so that it receives prefixes on its S0/0 interface but not S0/1. Do not use any access-list, distribute-list or route-map, or distance command. R1 should still advertise 10.1.13.0/24.

R1 Configuration:
!
router eigrp 1
 passive-interface Serial0/1
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
!

Notice!
The 'passive-interface' command prevents EIGRP (and OSPF) from sending the hello packets out this interface. As a result of that, there is no neighbor adjacency built on that interface and no EIGRP exchange occurs. However, the interface is still enabled for EIGRP and as such the IP address found on the interface (subnet/network) is still being advertised.

Pic. 2 - R1's EIGRP Interfaces.

Pic. 3 - R4's Routing Table.

Note!
In case there are many interfaces that should be 'passive' the 'passive-interface default' could be used with 'no passive-interface' option.

Thursday, March 17, 2011

Lab 49 - EIGRP Filtering with Administrative Distance

Prerequisites: CCNP level skills.

Note!
Use the basic EIGRP configuration (Lab 45 Task 1) in the labs 45-53.

EIGRP filtering can use:
  1. Standard ACL.
  2. Extended ACL.
  3. Prefix-List.
  4. Route-Map.
  5. Administrative Distance.
  6. Passive-Interface.
  7. Offset-List.
  8. Stub Routing.
  9. Selective Stub Routing (stub routing with leak map).
Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Using Administrative Distance, configure R4 so it does not install 172.16.133.0/24 in the routing table if it is advertised by R1, and 172.16.103.0/24 if it is advertised by R2.

Lab Solution

Pic. 2 - R4's Routing Table.

Task 1
Using Administrative Distance, configure R4 so it does not install 172.16.133.0/24 in the routing table if it is advertised by R1, and 172.16.103.0/24 if it is advertised by R2.

Notice!
Changing the distance for INTERNAL EIGRP prefixes can be done selectively (on per prefix basis).
Changing the distance for EXTERNAL EIGRP prefixes CANNOT be done selectively (either for all or none of them:
router eigrp 1
  distance eigrp 90 255).

R4 Configuration:
!
ip access-list standard R3_L0
 permit 172.16.103.0
ip access-list standard R3_L1
 permit 172.16.133.0
!
router eigrp 1
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 distance 255 10.1.124.1 0.0.0.0 R3_L1
 distance 255 10.1.124.2 0.0.0.0 R3_L0
!

Verification:
Pic. 3 -R4's Routing Table.