Thursday, June 7, 2012

Lab 170 - MultiProtocol BGP

Prerequisites: CCNP level skills.

Note!
This topology layout is based on the new physical topology presented here.

In previous lab (Lab 168) I have configured basic L3 reachability (point-to-point) as well as OSPF configuration in the core of the network (R1, R2, R3, SW3).


Topology


Pic. 1 - MPLS Topology.


Task 1
Enable Multiprotocol BGP on all PE routers.

Solution

Lab 169 - MPLS Basic Configuration

Prerequisites: CCNP level skills.

Note!
This topology layout is based on the new physical topology presented here.

In previous lab (Lab 168) I have configured basic L3 reachability (point-to-point) as well as OSPF configuration in the core of the network (R1, R2, R3, SW3).


Topology


Pic. 1 - MPLS Topology.

Task 1
Configure standard protocol used in MPLS networks on all PE and P routers. Make sure that PE routers do NOT run tagging protocol on their interfaces facing the customers.

Solution


Lab 168 - Creating MPLS Topology

Prerequisites: CCNP level skills.

Note!
This topology layout is based on the new physical topology presented here.

Topology

Task 1
Using the physical topology presented here configure the IP addressing according to the following diagram. Make sure that all routers and switches can ping each other on a point-to-point basis (All loopbacks use 10.0.x.x/24 addresses where x=router number, sw1=7, sw2=8 etc.).

Pic. 1 - MPLS Topology Diagram.


Task 2
Once devices can ping each other on a point-to-point basis, enable OSPF on links between R1, R2, R3 and SW3 (core of our MPLS network) Advertise loopback addresses as /32 prefixes. Use AREA 0.

Solution

Task 1
Using the physical topology presented here configure the IP addressing according to the following diagram. Make sure that all routers and switches can ping each other on a point-to-point basis (All loopbacks use 10.0.x.x/24 addresses where x=router number, sw1=7, sw2=8 etc.).

R1 Configuration:
!
interface Loopback0
 ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.12
 encapsulation dot1Q 12
 ip address 172.16.12.1 255.255.255.0
!
interface FastEthernet0/0.13
 encapsulation dot1Q 13
 ip address 172.16.13.1 255.255.255.0
!
interface FastEthernet0/0.15
 encapsulation dot1Q 15
 ip address 172.16.15.1 255.255.255.0
!
interface FastEthernet0/0.16
 encapsulation dot1Q 16
 ip address 172.16.16.1 255.255.255.0
!


R2 Configuration:

!
interface Loopback0
 ip address 10.0.2.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.12
 encapsulation dot1Q 12
 ip address 172.16.12.2 255.255.255.0
!
interface FastEthernet0/0.13
 encapsulation dot1Q 13
 ip address 172.16.13.3 255.255.255.0
!
!
interface FastEthernet0/0.23
 encapsulation dot1Q 23
 ip address 172.16.23.2 255.255.255.0
!        
interface FastEthernet0/0.29
 encapsulation dot1Q 29
 ip address 172.16.29.2 255.255.255.0
!        

R3 Configuration:
!
interface Loopback0
 ip address 10.0.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.23
 encapsulation dot1Q 23
 ip address 172.16.23.3 255.255.255.0
!
interface FastEthernet0/0.34
 encapsulation dot1Q 34
 ip address 172.16.34.3 255.255.255.0
!        
interface FastEthernet0/0.103
 encapsulation dot1Q 103
 ip address 172.16.103.3 255.255.255.0

R4 Configuration:
!
interface Loopback0
 ip address 10.0.4.4 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.34
 encapsulation dot1Q 34
 ip address 172.16.34.4 255.255.255.0
!
interface FastEthernet0/0.45
 encapsulation dot1Q 45
 ip address 172.16.45.4 255.255.255.0
!

R5 Configuration:
!
interface Loopback0
 ip address 10.0.5.5 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.15
 encapsulation dot1Q 15
 ip address 172.16.15.5 255.255.255.0
!
interface FastEthernet0/0.45
 encapsulation dot1Q 45
 ip address 172.16.45.5 255.255.255.0

R6 Configuration:
!
interface Loopback0
 ip address 10.0.6.6 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.16
 encapsulation dot1Q 16
 ip address 172.16.16.6 255.255.255.0
!

SW1 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 10.0.7.7 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/2
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/3
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/4
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/5
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/6
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/7
 shutdown
!
interface FastEthernet1/8
 shutdown
!
interface FastEthernet1/9
 switchport mode trunk
!
interface FastEthernet1/10
 shutdown
!
interface FastEthernet1/11
 switchport mode trunk
!
interface FastEthernet1/12
 shutdown
!
interface FastEthernet1/13
 switchport mode trunk
!
interface FastEthernet1/14
 shutdown
!
interface FastEthernet1/15
 shutdown
!
interface Vlan1
 no ip address
!
interface Vlan79
 ip address 172.16.79.7 255.255.255.0
!

SW2 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 10.0.8.8 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 shutdown
!
interface FastEthernet1/1
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/2
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/3
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/4
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/5
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/6
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/7
 switchport mode trunk
 shutdown
!
interface FastEthernet1/8
 switchport mode trunk
 shutdown
!
interface FastEthernet1/9
 switchport mode trunk
 shutdown
!
interface FastEthernet1/10
 switchport mode trunk
 shutdown
!
interface FastEthernet1/11
 switchport mode trunk
 shutdown
!
interface FastEthernet1/12
 switchport mode trunk
 shutdown
!
interface FastEthernet1/13
 switchport mode trunk
!
interface FastEthernet1/14
 switchport mode trunk
 shutdown
!
interface FastEthernet1/15
 switchport mode trunk
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan89
 ip address 172.16.89.8 255.255.255.0
!

SW3 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 10.0.9.9 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/1
 switchport mode trunk
 duplex full
 speed 100
!
interface FastEthernet1/2
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/3
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/4
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/5
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/6
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/7
 switchport mode trunk
 shutdown
!
interface FastEthernet1/8
 switchport mode trunk
 shutdown
!
interface FastEthernet1/9
 switchport mode trunk
!
interface FastEthernet1/10
 switchport mode trunk
 shutdown
!
interface FastEthernet1/11
 switchport mode trunk
 shutdown
!
interface FastEthernet1/12
 switchport mode trunk
 shutdown
!
interface FastEthernet1/13
 switchport mode trunk
 shutdown
!
interface FastEthernet1/14
 switchport mode trunk
 shutdown
!
interface FastEthernet1/15
 switchport mode trunk
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan29
 ip address 172.16.29.9 255.255.255.0
!
interface Vlan79
 ip address 172.16.79.9 255.255.255.0
!
interface Vlan89
 ip address 172.16.89.9 255.255.255.0
!
interface Vlan111
 ip address 172.16.111.9 255.255.255.0
!

SW4 Configuration:
!
vlan 12-13,15-16,23,29,34,45,79,89,103,111
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
 ip address 10.0.10.10 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 duplex full
 speed 100
!
interface FastEthernet1/1
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/2
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/3
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/4
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/5
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/6
 shutdown
 duplex full
 speed 100
!
interface FastEthernet1/7
 switchport mode trunk
 shutdown
!
interface FastEthernet1/8
 switchport mode trunk
 shutdown
!
interface FastEthernet1/9
 switchport mode trunk
 shutdown
!
interface FastEthernet1/10
 switchport mode trunk
 shutdown
!
interface FastEthernet1/11
 switchport mode trunk
!
interface FastEthernet1/12
 switchport mode trunk
 shutdown
!
interface FastEthernet1/13
 switchport mode trunk
 shutdown
!
interface FastEthernet1/14
 switchport mode trunk
 shutdown
!
interface FastEthernet1/15
 switchport mode trunk
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan103
 ip address 172.16.103.10 255.255.255.0
!

BB1 Configuration:
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/0.111
 encapsulation dot1Q 111
 ip address 172.16.111.254 255.255.255.0
!

Task 2
Once devices can ping each other on a point-to-point basis, enable OSPF on links between R1, R2, R3 and SW3 (core of our MPLS network) Advertise loopback addresses as /32 prefixes. Use AREA 0.

R1 Configuration:
!
router ospf 1
 log-adjacency-changes
 network 10.0.1.1 0.0.0.0 area 0
 network 172.16.12.1 0.0.0.0 area 0
 network 172.16.13.1 0.0.0.0 area 0
!

R2 Configuration:
!
router ospf 1
 log-adjacency-changes
 network 10.0.2.2 0.0.0.0 area 0
 network 172.16.12.2 0.0.0.0 area 0
 network 172.16.23.2 0.0.0.0 area 0
 network 172.16.29.2 0.0.0.0 area 0
!

R3 Configuration:
!
router ospf 1
 log-adjacency-changes
 network 10.0.3.3 0.0.0.0 area 0
 network 172.16.23.3 0.0.0.0 area 0
 network 172.16.13.3 0.0.0.0 area 0
!

SW3 Configuration:
!
router ospf 1
 log-adjacency-changes
 network 10.0.9.9 0.0.0.0 area 0
 network 172.16.29.9 0.0.0.0 area 0
!

In my next lab we're going to create MPLS basic configuration.

Stay tuned!

New Topology Diagram

After a looong hiatus regarding my blog updates I come back with new set of mini labs and new topology.

Please, watch the video introduction to get familiar with some changes in the blog.


My Dynamips (Dynagen) LAN connections look like shown below:

Pic. 1 - LAN Connections.
WAN links in my labs look as shown in the pic. 2:

Pic. 2 - WAN Connections.




If you use dynamips+dynagen on Linux (like myself) you might find the following topology file useful (keep in mind I start TWO instances of the dynamips hypervisor to off load the CPU).

MainTopology.net

#################################################
#                                                            
# Routing & Switching topology
# Author:   Jarek Rek
# Revision: 7 June 2012
# WWW:      http://hackingcisco.blogspot.com

#################################################

#################################################
#
# Define global router parameters for instance 1
#
#################################################

autostart=false
[localhost:7200]

workingdir = /home/jr/dynagen/labs/working

[[3725]]
 #
 # Specify 3725 IOS image:
 image = /home/jr/dynagen/ios/c3725-advipservicesk9-mz.124-15.T13.extracted.bin
 #
 ram = 128
 disk0 = 16
 disk1 = 0
 # Idlepc value
 idlepc = 0x60bc00b8
 mmap = true
 ghostios = true
 

###########################
#
# Define router instances
#
###########################

 [[Router R1]]
  model = 3725
  console = 2001
  autostart = false
  F0/0 = SW1 F1/1
  F0/1 = SW2 F1/1
  S0/0 = FRSW 1
 
 [[Router R2]]
  model = 3725
  console = 2002
  autostart = false
  slot1 = NM-4T
  F0/0 = SW1 F1/2
  F0/1 = SW2 F1/2
  S0/0 = FRSW 2
  S0/1 = R1 S0/1
  S1/0 = R3 S1/0
   

[[Router R3]]
  model = 3725
  console = 2003
  autostart = false
  slot1 = NM-4T
  F0/0 = SW1 F1/3
  F0/1 = SW2 F1/3
  S0/0 = FRSW 3
  S0/1 = FRSW 13
   
 [[Router R4]]
  model = 3725
  console = 2004
  autostart = false
  F0/0 = SW1 F1/4
  F0/1 = SW2 F1/4
  S0/0 = FRSW 4
  S0/1 = R5 S0/1
   

 [[Router R5]]
  model = 3725
  console = 2005
  autostart = false
  F0/0 = SW1 F1/5
  F0/1 = SW2 F1/5
  S0/0 = FRSW 5
   

 [[Router R6]]
  model = 3725
  console = 2006
  autostart = false
  F0/0 = SW1 F1/6
  F0/1 = SW2 F1/6
  S0/0 = FRSW 6
   

#################################################
#
# Define global router parameters for instance 2
#
#################################################

[localhost:7201]

workingdir = /home/jr/dynagen/labs/working

[[3725]]
 #
 # Specify 3725 IOS image:
 image = /home/jr/dynagen/ios/c3725-advipservicesk9-mz.124-15.T13.extracted.bin
 #
 ram = 128
 disk0 = 16
 disk1 = 0
 # Idlepc value
 idlepc = 0x60bc00b8
 mmap = true
 ghostios = true

###########################
#
# Define router instances
#
###########################
    
 [[Router SW1]]
  model = 3725
  console = 2007
  autostart = false
  slot1 = NM-16ESW
  F1/9 = SW3 F1/9
  F1/10 = SW3 F1/10
  F1/11 = SW4 F1/11
  F1/12 = SW4 F1/12
  F1/13 = SW2 F1/13
  F1/14 = SW2 F1/14


 [[Router SW2]]
  model = 3725
  console = 2008
  autostart = false
  slot1 = NM-16ESW
  F1/9 = SW4 F1/9
  F1/10 = SW4 F1/10
  F1/11 = SW3 F1/11
  F1/12 = SW3 F1/12
   

 [[Router SW3]]
  model = 3725
  console = 2009
  autostart = false
  slot1 = NM-16ESW
  F1/13 = SW4 F1/13
  F1/14 = SW4 F1/14
   

 [[Router SW4]]
  model = 3725
  console = 2010
  autostart = false
  slot1 = NM-16ESW
   

 [[Router BB1]]
  model = 3725
  console = 2011
  autostart = false
  F0/0 = SW3 F1/1
  F0/1 = SW4 F1/1
 
[[Router BB2]]
  model = 3725
  console = 2012
  autostart = false
  F0/0 = SW3 F1/2
  F0/1 = SW4 F1/2
 
[[Router BB3]]
  model = 3725
  console = 2013
  autostart = false
  F0/0 = SW3 F1/3
  F0/1 = SW4 F1/3
  
  [[FRSW FRSW]]

  # R1 to FRSW
   1:102 = 2:201
   1:103 = 3:301
   1:104 = 4:401
   1:105 = 5:501
   1:106 = 6:601

  # R2 to FRSW
   2:203 = 3:302
   2:204 = 4:402
   2:205 = 5:502
   2:206 = 6:602

  # R3 to FRSW
   3:304 = 4:403
   3:305 = 5:503
   3:306 = 6:603
   13:314 = 4:413
   13:316 = 6:613

  # R4 to FRSW
   4:405 = 5:504
   4:406 = 6:504

  # R6 to FRSW

***** END OF FILE *****

My next series of mini-labs (starting with Lab 168) will use the above layout until further notice.