Wednesday, September 26, 2012

Lab 190 - RIPng Prefix Summarization


Prerequisites: CCNP level skills.

Topology

Notice!
In order to proceed to the next lab you must first complete all the previous labs (from lab 188 onwards).

Pic1. Layer3 Topology Diagram.

Click the picture to enlarge it.

Task 1
Configure IPv6 addresses between SW2 and BB2 as follows:
  • SW2 (Vlan 208): 2001:0:0:D0::8/64 
  • BB2 (Fa0/0): 2001:0:0:D0::FE/64
Task 2
In BB2 configure four loopbacks using the following addresses:
  • Loopback 0: 2001:2:2:0::1/64
  • Loopback 1: 2001:2:2:1::1/64
  • Loopback 2: 2001:2:2:2::1/64
  • Loopback 3: 2001:2:2:3::1/64
Task 3
Enable RIPng with the identifier 'CCIE' between SW2 and BB2. Ensure that SW2 advertises only one learned from BB2. All other RIPng devices should be able to reach more specific prefixes advertised by BB2.

Solution

Task 1
Configure IPv6 addresses between SW2 and BB2 as follows:
  • SW2 (Vlan 208): 2001:0:0:D0::8/64 
  • BB2 (Fa0/0): 2001:0:0:D0::FE/64
SW2 Config:
!
ipv6 unicast-routing
!
interface Vlan208
 ip address 198.18.100.8 255.255.255.0
 ipv6 address 2001:0:0:D0::8/64
!

BB2 Config:
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 ip address 198.18.100.254 255.255.255.0
 speed 100
 full-duplex
 ipv6 address 2001:0:0:D0::FE/64
!

Task 2
In BB2 configure four loopbacks using the following addresses:
  • Loopback 0: 2001:2:2:0::1/64
  • Loopback 1: 2001:2:2:1::1/64
  • Loopback 2: 2001:2:2:2::1/64
  • Loopback 3: 2001:2:2:3::1/64

BB2 Config:
!
int Loopback 0
 ipv6 address 2001:2:2:0::1/64
!
int Loopback 1
 ipv6 address 2001:2:2:1::1/64
!
int Loopback 2
 ipv6 address 2001:2:2:2::1/64
!
int Loopback 3
 ipv6 address 2001:2:2:3::1/64
!

Task 3
Enable RIPng with the identifier 'CCIE' between SW2 and BB2. Ensure that SW2 advertises only one learned from BB2. All other RIPng devices should be able to reach more specific prefixes advertised by BB2.

SW2 Config:
!
interface Vlan208
 ip address 198.18.100.8 255.255.255.0
 ipv6 address 2001:0:0:D0::8/64
 ipv6 rip CCIE enable
!

BB2 Config:
!
interface FastEthernet0/0
 ip address 198.18.100.254 255.255.255.0
 speed 100
 full-duplex
 ipv6 address 2001:0:0:D0::FE/64
 ipv6 rip CCIE enable
 ipv6 rip CCIE summary-address 2001:2:2::/62
!
interface Loopback0
 no ip address
 ipv6 address 2001:2:2::1/64
 ipv6 rip CCIE enable
!
interface Loopback1
 no ip address
 ipv6 address 2001:2:2:1::1/64
 ipv6 rip CCIE enable
!
interface Loopback2
 no ip address
 ipv6 address 2001:2:2:2::1/64
 ipv6 rip CCIE enable
!
interface Loopback3
 no ip address
 ipv6 address 2001:2:2:3::1/64
 ipv6 rip CCIE enable
!

Verification:
Pic. 02 - Summary Prefix.

Pic. 03 - Ping Test.

Lab 189 - IPv6 Address Auto-Configuration


Prerequisites: CCNP level skills.

Topology


Pic2. Layer3 Topology Diagram.

Click the picture to enlarge it.

Task 1
Ensure, that you have configured previous lab correctly (lab 188). Configure SW1, SW2 and R5 such that they automatically configure their IPv6 addresses in Vlans 27 and Vlans 215. 

Task 2
Enable RIPng with the identifier 'CCIE' in SW1, SW2 and R5. Verify that SW1 can reach all the hosts in VLAN 215.

Notice!
In order to proceed to the next lab you must first complete all the previous labs (from lab 188 onwards).

Solution


Task 1
Ensure, that you have configured previous lab correctly (lab 188). Configure SW1SW2 and R5 such that they automatically configure their IPv6 addresses in Vlans 27 and Vlans 215. 

SW1 Config:
!
ipv6 unicast-routing
!
interface Vlan27
 ip address 172.16.27.7 255.255.255.0
 ipv6 address autoconfig
!

SW2 Config:
!
ipv6 unicast-routing
!
interface Vlan215
 ip address 172.16.215.8 255.255.255.0
 ipv6 address autoconfig
!

R5 Config:
!
ipv6 unicast-routing
!
interface FastEthernet0/1
 ip address 172.16.215.5 255.255.255.0
 speed 100
 full-duplex
 ipv6 address autoconfig
!

Using 'debug ipv6 nd' and 'debug ipv6 packet detail' inspect what happens when you enable autoconfig.


Task 2
Enable RIPng with the identifier 'CCIE' in SW1SW2 and R5. Verify that SW1 can reach all the hosts in VLAN 215.

SW1 Config:
!
interface Vlan27
 ip address 172.16.27.7 255.255.255.0
 ipv6 address autoconfig
 ipv6 rip CCIE enable
!

SW2 Config:
!
interface Vlan215
 ip address 172.16.215.8 255.255.255.0
 ipv6 address autoconfig
 ipv6 rip CCIE enable
!


R5 Config:
!
interface FastEthernet0/1
 ip address 172.16.215.5 255.255.255.0
 speed 100
 full-duplex
 ipv6 address autoconfig
 ipv6 rip CCIE enable
!

Saturday, September 22, 2012

Lab 188 - RIPng Basic Configuration


Prerequisites: CCNP level skills.

Topology


Pic2. Layer3 Topology Diagram.

Click the picture to enlarge it.

Task 1
Configure IPv6 network addresses as follows:
  • R1's FastEthernet0/1 = 2001:0:0:D7::/64
  • R2's FastEthernet0/0 = 2001:0:0:1B::/64
Ensure that the host id is created automatically (off of a router's MAC address)

Task 2
Enable RIPng with the identifier 'CCIE' allowing traffic between Vlan 27 and Vlan 215. Ensure that R1 and R2 can ping their respective Vlans using router's host names as well. Assume there is no IPv6 DNS server in the network.

Solution

Lunch break at work and I am playing in the lab. How geeky am I?


Task 1
Configure IPv6 network addresses as follows:
  • R1's FastEthernet0/1 = 2001:0:0:D7::/64
  • R2's FastEthernet0/0 = 2001:0:0:1B::/64
Ensure that the host id is created automatically (off of a router's MAC address)

R1 Config:
!
interface FastEthernet0/1
 ip address 172.16.215.1 255.255.255.0
 speed 100
 full-duplex
 ipv6 address 2001:0:0:D7::/64 eui-64
!

R2 Config:
!
interface FastEthernet0/0
 ip address 172.16.27.2 255.255.255.0
 speed 100
 full-duplex
 ipv6 address 2001:0:0:1B::/64 eui-64
!


Task 2
Enable RIPng with the identifier 'CCIE' allowing traffic between Vlan 27 and Vlan 215. Ensure that R1 and R2 can ping their respective Vlans using router's host names as well. Assume there is no IPv6 DNS server in the network.

R1 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
interface Serial0/0
 ip address 172.16.123.1 255.255.255.0
 encapsulation frame-relay
 ipv6 address FE80::1 link-local
 ipv6 address 2001:0:0:123::1/64
 ipv6 rip CCIE enable
 clock rate 2000000
 frame-relay map ip 172.16.123.2 102 broadcast
 frame-relay map ipv6 2001:0:0:123::2 102
 frame-relay map ipv6 FE80::2 102 broadcast
 no frame-relay inverse-arp
!

R2 Config:
!
ipv6 unicast-routing
!
ipv6 router rip CCIE
!
interface Serial0/0
 ip address 172.16.123.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address FE80::2 link-local
 ipv6 address 2001:0:0:123::2/64
 ipv6 rip CCIE enable
 clock rate 2000000
 frame-relay map ip 172.16.123.3 203 broadcast
 frame-relay map ip 172.16.123.2 201
 frame-relay map ip 172.16.123.1 201 broadcast
 frame-relay map ipv6 2001:0:0:123::1 201
 frame-relay map ipv6 FE80::1 201 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/0
 ip address 172.16.27.2 255.255.255.0
 speed 100
 full-duplex
 ipv6 address 2001:0:0:1B::/64 eui-64
 ipv6 rip CCIE enable
!

Notice!
You don't have to enable RIPng process in the global config mode. You can enable it directly on the interface(es) instead. The global process will start automatically.

In order to ping the routers by their names without DNS service, you must create ip host mappings (hosts). Your IPv6 addresses will be different than mine here:

R2's Fa0/0 IPv6 address = 2001::1B:C001:AFF:FE16:0
R1's Fa0/1 IPv6 address = 2001::D7:C000:AFF:FE16:1

R1 Config:
!
ipv6 host R2 2001::1B:C001:AFF:FE16:0
!

R2 Config:
!
ipv6 host R1 2001::D7:C000:AFF:FE16:1
!

Verification:
#show hosts

Ping works!

Tuesday, September 18, 2012

Lab 187 - IPv6 On Frame-Relay Links

Prerequisites: CCNP level skills.

Topology


Pic2. Layer3 Topology Diagram.

Click the picture to enlarge it.

Task 1
You plan on using IPv6 in your network. As an experiment, you want to enable dual stack on Frame-Relay enabled links between R1, and R2 which will support RIPng protocol. Below are the addresses you should use:

R1 Serial0/0:
link local address = FE80::1
Globally aggregatable address: 2001:0:0:123::1/64

R2 Serial0/0:
link local address = FE80::2
Globally aggregatable address: 2001:0:0:123::2/64


Task 2
Ensure basic layer 3 connectivity and make sure that RIPng will be able to exchange updates using Frame-Relay interfaces.


Solution

R1 Config:
!
ipv6 unicast-routing
!
interface Serial0/0
 ip address 172.16.123.1 255.255.255.0
 encapsulation frame-relay
 ipv6 address FE80::1 link-local
 ipv6 address 2001:0:0:123::1/64
 clock rate 2000000
 frame-relay map ipv6 FE80::2 102 broadcast
 frame-relay map ipv6 2001:0:0:123::2 102
 frame-relay map ip 172.16.123.2 102 broadcast
 no frame-relay inverse-arp
!


R2 Config:
!
ipv6 unicast-routing
!
interface Serial0/0
 ip address 172.16.123.2 255.255.255.0
 encapsulation frame-relay
 ipv6 address FE80::2 link-local
 ipv6 address 2001:0:0:123::2/64
 clock rate 2000000
 frame-relay map ipv6 FE80::1 201 broadcast
 frame-relay map ipv6 2001:0:0:123::1 201
 frame-relay map ip 172.16.123.1 201 broadcast
 frame-relay map ip 172.16.123.2 201
 frame-relay map ip 172.16.123.3 203 broadcast
 no frame-relay inverse-arp

!

Monday, September 17, 2012

Lab 186 - Creating IPv6 Topology

Prerequisites: CCNP level skills.

Topology

The most boring part is changing the topology every now and then just to illustrate the problem. In order to avoid doing this over and over again, let's use the same physical topology I have used in the Kill Switch section. 

The logical configuration used from now on, will be the same I have used in Green Sash: OSPF sub-section. We have only one life and it is better if we spend it on doing something interesting.


Pic1. Layer2 Topology Diagram.

Pic2. Layer3 Topology Diagram.

Click the picture to enlarge it.

Task 1
Using the physical topology diagram presented here, configure devices as per pic.1 and pic.2 (if you want to save the time, you can download the configurations from here and upload it).

Task 2
Test layer 3 connectivity between all neighboring devices.

Task 3
Get ready for the upcoming IPv6 labs ;).


Friday, September 7, 2012

Hacking Cisco - Lab List


Disclaimer
The author of the posts will not assume any liability or responsibility to any person or entity with respect to loss or damages incurred from information contained in this blog. Any resemblance to some other training materials and/or CCIE exam is completely coincidental.



Last Update: 7, September 2012


Hello. 

My name is Jarek Rek (first name pronounced like: 'Yarek'). I would like to welcome you to my Cisco Routing blog. I try to develop my skills in the area of linux, routing and switching as well as programming every day. I am greatly inspired by open source movement and the content of this site partly reflects my attitude towards life and people. I believe that through hard work, honing the skills, sharing and helping one another, amazing things can happen. If you are now laughing at my naivete, consider the contributions made by Linus Torvalds and thousands of hackers who shared their expertise with us.

Anyway, if you want to tag along and study with me you are most welcome. I will be very happy to hear from you. If you want to drop me a line you will find my contact details in 'about me' section.


Thank you for visiting my blog. I wish you all the best with your personal goals.
Enjoy the labs.


Version 0.1 (draft)
Cisco Routing and Switching (mini) Challenges

Categories:
OSPF | EIGRP | RIPv2 | BGP | Multicast | MPLS | IPv6 |

**** OSPF ****

Lab 001 - OSPF Point-to-Point Mode
Lab 001 - OSPF Point-to-Point Mode - Solution
Lab 002 - OSPF in Broadcast Networks
Lab 003 - OSPF in NBMA Networks
Lab 004 - OSPF in Point-to-Multipoint
Lab 005 - OSPF in Point-to-Multipoint Non-broadcast
Lab 006 - OSPF Multi-Area Network
Lab 007 - OSPF Authentication
Lab 008 - OSPF Filtering with Distribute-List
Lab 009 - OSPF Filtering with Route-Map
Lab 010 - OSPF Filtering with Distance
Lab 011 - OSPF Filtering with Area Range
Lab 012 - OSPF Filtering with Area Filter-List
Lab 013 - OSPF LSA Flood Filtering
Lab 014 - OSPF Stub Area
Lab 015 - OSPF Totally Stubby Area
Lab 016 - OSPF NSSA Area LSA7-to-5 Translation
Lab 017 - OSPF NSSA Totally Stub Area
Lab 018 - OSPF FA Suppression in Translated Type-5 LSAs
Lab 019 - OSPF External Prefix Filtering
Lab 020 - OSPF Path Influencing Using Cost
Lab 021 - OSPF Path Influencing Using Bandwidth
Lab 022 - OSPF Path Influencing Using Neighbor Cost
Lab 023 - OSPF Changing Auto-Cost Reference-Bandwidth
Lab 024 - OSPF Virtual Link Example 1
Lab 025 - OSPF Virtual Link Example 2
Lab 026 - OSPF Virtual Link Example 3
Lab 027 - OSPF Path Selection with Transit Capability
Lab 028 - OSPF Stub Router Advertisement
Lab 029 - OSPF Reducing LSA Flooding
Lab 030 - OSPF On Demand Circuits
Lab 031 - OSPF Default Routing
Lab 032 - OSPF Conditional Default Routing
Lab 033 - OSPF Conditional Default Routing with IP SLA
Lab 034 - OSPF Discard Route
Lab 035 - OSPF Resource Management
Lab 036 - OSPF Timers
Lab 037 - OSPF Other Features

**** EIGRP ****

Lab 038 - EIGRP NBMA Network
Lab 039 - EIGRP Automatic Summarization
Lab 040 - EIGRP Manual Summarization
Lab 041 - EIGRP Summarization with Default Route
Lab 042 - EIGRP Summarization with a Floating Default Route
Lab 043 - EIGRP Summarization with Administrative Distance 255
Lab 044 - EIGRP Selective Summarization with a Leak Map
Lab 045 - EIGRP Filtering with Standard ACL
Lab 046 - EIGRP Filtering with Extended ACL
Lab 047 - EIGRP Filtering with Prefix-List
Lab 048 - EIGRP Filtering with Route-Map
Lab 049 - EIGRP Filtering with Administrative Distance
Lab 050 - EIGRP Filtering with Passive-Interface
Lab 051 - EIGRP Filtering with Offset-List
Lab 052 - EIGRP Filtering with Stub Routing
Lab 053 - EIGRP Filtering with Stub Routing and Leak Map
Lab 054 - EIGRP Default Route Advertisement
Lab 055 - EIGRP Unequal Cost Load Balancing
Lab 056 - EIGRP Traffic Engineering with the Delay
Lab 057 - Frame-Relay Packet Pacing
Lab 058 - EIGRP Authentication
Lab 059 - EIGRP Router ID
Lab 060 - EIGRP Unicast Communication
Lab 061 - EIGRP Timers
Lab 062 - EIGRP Other Features


**** RIPv2 ****



**** BGP ****

Lab 081 - BGP Internal Session (IBGP)
Lab 082 - BGP External Session (EBGP) and Advertisements
Lab 083 - BGP Synchronization
Lab 084 - BGP Next-Hop on Broadcast and NBMA Networks
Lab 085 - EBGP Multihop
Lab 086 - BGP Disable-Connected-Check
Lab 087 - BGP Authentication
Lab 088 - BGP Auto-Summary
Lab 089 - non-BGP Transit with IGP Redistribution
Lab 090 - non-BGP Transit with GRE Tunnel
Lab 091 - non-BGP Transit with MPLS
Lab 092 - BGP Next-Hop Modification
Lab 093 - IBGP Route-Reflector
Lab 094 - BGP Confederations
Lab 095 - BGP Path Selection using Weight
Lab 096 - BGP Path Selection using Local Preference
Lab 097 - BGP Path Selection using MED
Lab 098 - BGP Path Selection Always-Compare-MED
Lab 099 - BGP Path Selection using AS-Prepending
Lab 100 - BGP Hidden Feature BESTPATH AS-PATH IGNORE
Lab 101 - BGP Path Selection Using Origin
Lab 102 -  BGP Path Selection using DMZLINK-BW
Lab 103 - BGP Path Selection using MAXAS-LIMIT
Lab 104 - BGP Filtering using Standard ACL
Lab 105 - BGP Filtering using Extended ACL
Lab 106 - BGP Filtering using Prefix-List
Lab 107 - BGP Aggregation using IP Route Null0
Lab 108 - BGP Aggregation using Aggregate-Address
Lab 109 - BGP Aggregation with Unsuppress-Map
Lab 100 - BGP Aggregation with Suppress-Map
Lab 111 - BGP Aggregation with AS-SET
Lab 112 - BGP Aggregation with ATTRIBUTE-MAP
Lab 113 - BGP Aggregation with ADVERTISE-MAP
Lab 114 - BGP Communities - NO-EXPORT
Lab 115 - BGP Communities - NO-ADVERTISE
Lab 116 - BGP Communities - LOCAL-AS
Lab 117 - BGP Community Policy
Lab 118 - BGP Conditional Route Advertisement Part 1
Lab 119 - BGP Conditional Route Injection
Lab 120 - BGP Default Route Advertisement
Lab 121 - BGP Conditional Route Advertisement Part 2
Lab 122 - BGP AS-Path Access-List
Lab 123 - BGP Local-AS
Lab 124 - BGP Local-AS No-prepend
Lab 125 - BGP Local-AS No-prepend Replace-AS
Lab 126 - BGP Local-AS No-prepend Dual-AS
Lab 127 - BGP Allowas-In
Lab 128 - BGP Remove-Private-AS
Lab 129 - BGP Next-Hop using Next-Hop-Self
Lab 130 - BGP Next-Hop using Route-map
Lab 131 - BGP Next-Hop using Redistribution into IGP
Lab 132 - BGP Dampening
Lab 133 - BGP Dampening using Route-Map
Lab 134 - BGP Backdoor
Lab 135 - BGP TTL Security


**** Multicast ****



**** MPLS ****

Lab 177 - MPLS Overlapping VPNs
Lab 178 - MPLS Common Services VPN
Lab 179 - MPLS Internet Access (via global routing table)
Lab 180 - MPLS Internet Access (as VPN)
Lab 181 - MPLS BGP Cost Community
Lab 182 - EIGRP SoO
Lab 183 - AToM Vlan Mode
Lab 184 - L2TPv3
Lab 185 - MPLS L2 VPN



Cisco Fundamentals Study (CCNA): http://ciscoiseasy.blogspot.com 
News on Twitter: http://twitter.com/jarek_rek