Wednesday, March 16, 2011

Lab 45 - EIGRP Filtering with Standard ACL

Prerequisites: CCNP level skills.

Note!
Use the basic EIGRP configuration (Task 1) in the labs 45-53.

EIGRP filtering can use:
  1. Standard ACL.
  2. Extended ACL.
  3. Prefix-List.
  4. Route-Map.
  5. Administrative Distance.
  6. Passive-Interface.
  7. Offset-List.
  8. Stub Routing.
  9. Selective Stub Routing (stub routing with leak map).
Topology

Pic. 1 - Topology Diagram.
Icons designed by: Andrzej Szoblik - http://www.newo.pl

Task 1
Configure EIGRP according to the topology diagram (pic. 1).
Make sure that R4 has two paths towards towards Loopback 0 and Loopback 1 of R3.

Task 2
On R1 create a standard ACL based filtering so that it prefers the next hop 10.1.13.3 towards 172.16.103.3 and the next-hop 10.1.123.0/24 towards 172.16.133.0/24.

Lab Solution

Task 1
Configure EIGRP according to the topology diagram (pic. 1).
Make sure that R4 has two paths towards towards Loopback 0 and Loopback 1 of R3.

R1 Configuration:
!
interface Loopback0
 ip address 172.16.101.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.1.123.2 103
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 no auto-summary
!

R2 Configuration:
!
interface Loopback0
 ip address 172.16.102.2 255.255.255.0
!
interface Serial0/0
 ip address 10.1.123.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 10.1.123.1 203
 frame-relay map ip 10.1.123.3 203 broadcast
 no frame-relay inverse-arp
!
router eigrp 1
 network 10.1.123.2 0.0.0.0
 network 10.1.124.2 0.0.0.0
 network 172.16.102.2 0.0.0.0
 no auto-summary
!

R3 Configuration:
!
interface Loopback0
 ip address 172.16.103.3 255.255.255.0
!
interface Loopback1
 ip address 172.16.133.3 255.255.255.0
!
interface Serial0/0
 ip address 10.1.123.3 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 serial restart-delay 0
 frame-relay map ip 10.1.123.1 301 broadcast
 frame-relay map ip 10.1.123.2 302 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 10.1.13.3 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 10.1.13.3 0.0.0.0
 network 10.1.123.3 0.0.0.0
 network 172.16.103.3 0.0.0.0
 network 172.16.133.3 0.0.0.0
 no auto-summary
!

R4 Configuration:
!
interface Loopback0
 ip address 172.16.104.4 255.255.255.0
!
interface Loopback1
 ip address 172.16.144.4 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.1.124.4 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 10.1.124.4 0.0.0.0
 network 172.16.104.4 0.0.0.0
 network 172.16.144.4 0.0.0.0
 no auto-summary
!

Verification:
Pic. 2 - R4's Routing Table.
Task 2
On R1 create a standard ACL based filtering so that it prefers the next hop 10.1.13.3 towards 172.16.103.3 and the next-hop 10.1.123.0/24 towards 172.16.133.0/24.

Pic. 3 - Current Routing Table on R1.
R1 Configuration:
!
access-list 1 deny   172.16.133.0 0.0.0.255
access-list 1 permit any
access-list 2 deny   172.16.103.0 0.0.0.255
access-list 2 permit any
!
router eigrp 1
 network 10.1.13.1 0.0.0.0
 network 10.1.123.1 0.0.0.0
 network 10.1.124.1 0.0.0.0
 network 172.16.101.1 0.0.0.0
 distribute-list 2 in Serial0/0
 distribute-list 1 in Serial0/1
 no auto-summary
!

Notice!
After applying the distribute lists it takes about 3-5 seconds to re-synch neighbors.

Verification:
Pic. 4 - EIGRP Routing Table on R1.