Prerequisites: CCNP level skills.
Note!
Topology from Lab 118.
Topology
Task 1
Configure R3 so that it advertises the default route only to R1. This default route should be advertised only if the interface between R3 and R5 is up.
Solution
NOTICE!
R3 should have default route configured in order to advertise it using bgp (for instance:
ip route 0.0.0.0 0.0.0.0 null0
Task 1
Configure R3 so that it advertises the default route only to R1. This default route should be advertised only if the interface between R3 and R5 is up.
Pic. 2 - R3 Has no Default Route Before Applying Configuration.
!
ip route 0.0.0.0 0.0.0.0 null0
!
ip route 0.0.0.0 0.0.0.0 null0
!
ip prefix-list R3_R5_LINK seq 5 permit 10.1.35.0/24
!
route-map DEFAULT_ROUTE permit 10
match ip address prefix-list R3_R5_LINK
!
router bgp 30
no synchronization
bgp router-id 172.16.103.3
bgp log-neighbor-changes
network 172.16.103.0 mask 255.255.255.0
neighbor 10.1.13.1 remote-as 10
neighbor 10.1.13.1 default-originate route-map DEFAULT_ROUTE
neighbor 10.1.23.2 remote-as 20
neighbor 10.1.35.5 remote-as 50
no auto-summary
match ip address prefix-list R3_R5_LINK
!
router bgp 30
no synchronization
bgp router-id 172.16.103.3
bgp log-neighbor-changes
network 172.16.103.0 mask 255.255.255.0
neighbor 10.1.13.1 remote-as 10
neighbor 10.1.13.1 default-originate route-map DEFAULT_ROUTE
neighbor 10.1.23.2 remote-as 20
neighbor 10.1.35.5 remote-as 50
no auto-summary
!
Verification:
Pic. 3 - R1's BGP Table.
Pic. 4 - R2's BGP Table.
Only R1 receives the default route.
Now, shutting down the E0/0 on R3.
Pic. 5 - Link between R3 and R5 is Down.
Pic. 6 - R1 Loses the Default Route.